Closed Bug 720613 Opened 8 years ago Closed 8 years ago

java.lang.RuntimeException: Screen size of (480,800) larger than maximum texture size of 0 at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.geometryChanged(GeckoSoftwareLayerClient.java:242)

Categories

(Firefox for Android :: General, defect, P2, critical)

12 Branch
ARM
Android
defect

Tracking

()

RESOLVED FIXED
Firefox 12
Tracking Status
firefox11 --- verified
firefox12 --- verified
firefox13 --- verified
fennec 11+ ---

People

(Reporter: nhirata, Assigned: cwiiis)

Details

(Keywords: crash, topcrash, Whiteboard: [native-crash])

Crash Data

Attachments

(1 file)

at least 403 crashes with this signature:

java.lang.RuntimeException: Screen size of (480,800) larger than maximum texture size of 0
	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.geometryChanged(GeckoSoftwareLayerClient.java:242)
	at org.mozilla.gecko.gfx.LayerController.notifyLayerClientOfGeometryChange(LayerController.java:275)
	at org.mozilla.gecko.ui.PanZoomController$BounceRunnable.advanceBounce(PanZoomController.java:610)
	at org.mozilla.gecko.ui.PanZoomController$BounceRunnable.run(PanZoomController.java:595)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Looper.loop(Looper.java:130)
	at org.mozilla.gecko.GeckoApp$28.run(GeckoApp.java:1403)
	at android.os.Handler.handleCallback(Handler.java:587)
	at android.os.Handler.dispatchMessage(Handler.java:92)
	at android.os.Lo


e11a570e-3d35-4a40-bc7e-fc4162111222
4c1777b5-3e34-4b71-91fe-aa9a62111225
a8358e63-db7e-4c02-958a-5361a2111225
eda7b1a9-14e8-42ff-b690-283ec2111225
This can't be good.
Crash Signature: mozalloc_abort | __swrite | dexDataMapAlloc → [@ mozalloc_abort | __swrite | dexDataMapAlloc]
Assignee: nobody → pwalton
Punting over to Chris while I focus on tiling work.
Assignee: pwalton → chrislord.net
I guess the BounceRunnable is either running before onSurfaceCreated() finishes, or (less likely) racing with it.

We need to make sure the PZC doesn't get to do anything before that method runs.
I don't actually know whether this definitely fixes it, as I don't have a way of reliably reproducing this crash.

Would it be possible for anyone that experiences this crash to test it out, or for someone to provide reasonably reliable reproduction instructions?
Attachment #592642 - Flags: review?(pwalton)
tracking-fennec: --- → 11+
Priority: -- → P2
Comment on attachment 592642 [details] [diff] [review]
Prevent resizing buffer before surface creation

Review of attachment 592642 [details] [diff] [review]:
-----------------------------------------------------------------

r+ with nit addressed

::: mobile/android/base/gfx/GeckoSoftwareLayerClient.java
@@ +427,5 @@
> +        if (!force &&
> +            (metrics.widthPixels == mScreenSize.width &&
> +             metrics.heightPixels == mScreenSize.height) ||
> +            (getLayerController() != null &&
> +             !getLayerController().getViewportSize().isPositive())) {

Could you split this up into multiple ifs and returns? The logic is a little confusing.
Attachment #592642 - Flags: review?(pwalton) → review+
https://hg.mozilla.org/mozilla-central/rev/43db43f13cde
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
patrick, should this be uplifted?
Comment on attachment 592642 [details] [diff] [review]
Prevent resizing buffer before surface creation

Yes.

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Possible crash.
Testing completed (on m-c, etc.): Nightly testing.
Risk to taking this patch (and alternatives if risky): Low risk.
String changes made by this patch:
Attachment #592642 - Flags: approval-mozilla-aurora?
Comment on attachment 592642 [details] [diff] [review]
Prevent resizing buffer before surface creation

[Triage Comment]
already on aurora, approving for beta
Attachment #592642 - Flags: approval-mozilla-aurora? → approval-mozilla-beta+
This issue is no longer reproducible on the latest Fennec builds. Closing bug as verified fixed on:

Firefox 13.0a1 (2012-02-24)
20120224031039
http://hg.mozilla.org/mozilla-central/rev/cd120efbe4c6

Firefox 12.0a2 (2012-02-24)
20120224042008
http://hg.mozilla.org/releases/mozilla-aurora/rev/643e4dd65350

Firefox 11.0 (2012-02-24)
20120223235138
http://hg.mozilla.org/releases/mozilla-beta/rev/0e30f13e9012

--
Device: Motorola Droid 2
OS: Android 2.3.3
Crash Signature: [@ mozalloc_abort | __swrite | dexDataMapAlloc] → [@ mozalloc_abort | __swrite | dexDataMapAlloc] [@ java.lang.RuntimeException: Screen size of (854 480) larger than maximum texture size of 0 at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.sendResizeEventIfNecessary(GeckoSoftwareLayerClient.java) ] […
You need to log in before you can comment on or make changes to this bug.