Avoid crashing when library loading fails somehow

REOPENED
Unassigned

Status

()

Firefox for Android
General
P3
enhancement
REOPENED
6 years ago
a year ago

People

(Reporter: glandium, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=java])

(Reporter)

Description

6 years ago
Currently, when the linker fails to load libraries, Fennec just crashes. Considering we have a native UI, we could avoid that and do something useful instead, like displaying a message, exiting properly, and/or even allow to download the next nightly.

Updated

6 years ago
tracking-fennec: --- → ?
tracking-fennec: ? → +

Comment 1

6 years ago
Mike, No one is looking at this.  Is this something you prototyped up?
Severity: normal → enhancement
Priority: -- → P3
(Reporter)

Comment 2

6 years ago
No, I just have patches that delay the crash. (that is avoid a crash in loadLibs, but then crash when JNI is called from java code)
Whiteboard: [mentor=kats]

Comment 3

5 years ago
I'm presuming about the language here; feel free to correct me.
Whiteboard: [mentor=kats] → [mentor=kats][language=java]
Yup. And actually I realize now somebody from the frontend team would be better since this mostly involves throwing up some pretty Android UI and shutting down properly.
Whiteboard: [mentor=kats][language=java] → [mentor=bnicholson][language=java]

Updated

5 years ago
Whiteboard: [mentor=bnicholson][language=java] → [mentor=bnicholson][lang=java]
So what would we want here? Just some dialog with a string and an OK button?

Via IRC, Kats said that one possible cause of this lib load failing would be loading an ARMv7 build on an ARMv6 device, but that there is no way to distinguish that from other causes of the same crash. So is there anything useful we could actually give to the user at this point to help figure out the problem? If not, I'm not sure I see how this is an improvement over the crash reporter UI.
(Reporter)

Comment 6

4 years ago
In that case you wouldn't get the crash reporter UI.
(Assignee)

Updated

4 years ago
Mentor: bnicholson@mozilla.com
Whiteboard: [mentor=bnicholson][lang=java] → [lang=java]
I think this is fixed via bug 990130.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

4 years ago
AIUI, bug 990130 handled the case of the mozglue library failing to load, not gecko libraries.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mentor: bnicholson@mozilla.com
Since the last update is more than 2 years, we are removing the tracking-fennec flag for now.
Feel free to renominate the bug if it happens again and it's reproducible. 

Thank you !
tracking-fennec: + → ---
You need to log in before you can comment on or make changes to this bug.