Junkbuster ability in Mozilla?

RESOLVED DUPLICATE of bug 69758

Status

SeaMonkey
General
--
enhancement
RESOLVED DUPLICATE of bug 69758
17 years ago
12 years ago

People

(Reporter: Mystic, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Isn't it a good idea to implement the concept of Internet Junkbuster
(http://www.junkbuster.com/ijb.html) into the code of Mozialla?  Includes a lot 
of user customisation like cookies accptance/denial based on sites, images to 
be blocked, denu popups etc?

One can always set it to a default setting that gives the exact working of 
Moziall as it is now, thus making sure that inexperienced users are 
not "troubled"!

Comment 1

17 years ago
Mozilla already has user-controlled cookie acceptance and denial on a
site-by-site basisis, and it already has the ability to deny sites the ability
to create javascript popup windows (although there is no user-interface witten
for that one yet)

Comment 2

17 years ago
Is there a bug for the lack of UI?
Lack of UI for which in particular?  The cookie and image stuff has UI.

The JS stuff is bug 38966 as far as I can tell.
(Reporter)

Comment 4

17 years ago
I realise that Mozilla already has the ability to deny cookies on a site basis 
and deny pop ups.. but what I was looking for was an integrated UI. The images 
should be blocked site basis as well as string regex basis- like all images 
tags with word "ads" whould be blocked or even better replaced with a locally 
stored 1x1 images, so that page layout is not effected.
You can deny images and cookies on a per-site basis and there is UI for this
(see advanced preferences).

See bug 69758 for the regular expression rfe.

bug 38966 covers the integrated UI you speak of.

What part of your feature request is not covered yet?



Severity: normal → enhancement
(Reporter)

Comment 6

17 years ago
Boris,
Thanks for pointing it out to me. Yup, as you said, looks like the bug seems to 
be already present. But I did not like the reply one which said, "You will have 
to do it yourself".

I haven't dug into the Mozilla code, but can't it use the Junkbuster codes as a 
starting point to build the feature?
(Reporter)

Comment 7

17 years ago
So the comclusion of the bug #72072 is that it has already been brought up and 
will be taken care of part by part?

Comment 8

17 years ago
Yup..duping.

*** This bug has been marked as a duplicate of 69758 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.