Last Comment Bug 720721 - Pdf.js rendering broken with Coregraphics azure canvas
: Pdf.js rendering broken with Coregraphics azure canvas
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Jeff Muizelaar [:jrmuizel]
:
Mentors:
: 720909 (view as bug list)
Depends on: 728028
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 09:03 PST by Jeff Muizelaar [:jrmuizel]
Modified: 2012-02-18 23:09 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Make sure the clip is transformed (587 bytes, patch)
2012-01-24 11:45 PST, Jeff Muizelaar [:jrmuizel]
no flags Details | Diff | Splinter Review
Handle pushClipRect too and add a reftest (3.01 KB, patch)
2012-01-24 12:17 PST, Jeff Muizelaar [:jrmuizel]
matt.woodrow: review+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2012-01-24 09:03:31 PST
http://mozilla.github.com/pdf.js/web/viewer.html#page=1&zoom=auto,0,-149

The diagram is clipped when it shouldn't be.
Comment 1 Jeff Muizelaar [:jrmuizel] 2012-01-24 09:09:12 PST
Julian, is there any easy way that we can reduce this test case? Is it possible to record the canvas commands and produce a single piece of js that renders that page that we could reduce manually?
Comment 2 Julian Viereck 2012-01-24 09:43:41 PST
It's not that 'easy' but I can hack something up. It won't display the fonts correct, but I guess that shouldn't bother to reduce the test case.
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-01-24 11:45:37 PST
Created attachment 591202 [details] [diff] [review]
Make sure the clip is transformed

This fixes the issue.
Comment 4 Jeff Muizelaar [:jrmuizel] 2012-01-24 12:17:40 PST
Created attachment 591213 [details] [diff] [review]
Handle pushClipRect too and add a reftest
Comment 5 Jeff Muizelaar [:jrmuizel] 2012-01-24 19:48:16 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/3c47bcef2ce4
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2012-01-25 07:06:08 PST
https://hg.mozilla.org/mozilla-central/rev/3c47bcef2ce4
Comment 7 Jeff Muizelaar [:jrmuizel] 2012-01-26 09:04:50 PST
*** Bug 720909 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.