Closed Bug 720743 Opened 8 years ago Closed 8 years ago

Linux repack 6/6 timed out for the 3.6.26 release

Categories

(Release Engineering :: Release Automation: Other, defect, P3)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 628386

People

(Reporter: armenzg, Assigned: armenzg)

Details

Attachments

(1 file)

Attached file log
It timed out cloning mozilla-1.9.2
Not sure for what reason.
I re-triggered the job.

retry: Calling <function getReleaseLocalesForChunk at 0x8c54b8c> with args: ('firefox', 'browser', '3.6.26', 1, 'releases/mozilla-1.9.2', 'linux', 6, 6), kwargs: {}, attempt #1
retry: Calling <function mercurial at 0x8c54224> with args: ('http://hg.mozilla.org/releases/mozilla-1.9.2', 'mozilla-1.9.2'), kwargs: {}, attempt #1
Checking if share extension works
command: START
command: hg help share
command: cwd: /builds/slave/rel-m-192-lnx-rpk-6
command: output:
command: END (0.18 elapsed)

Updating shared repo
command: START
command: hg clone -U http://hg.mozilla.org/releases/mozilla-1.9.2 /builds/hg-shared/releases/mozilla-1.9.2
command: cwd: /builds/slave/rel-m-192-lnx-rpk-6
command: output:

command timed out: 1200 seconds without output, attempting to kill
process killed by signal 9
program finished with exit code -1
elapsedTime=1409.970875
In the meeting we determine that we want to:
* bump the timeout
* this happened on an IX machine on MTV while other clones were happening (other repack jobs)
** we probably hammered hg
** the new colo might make things more reliable
Armen, this should be a simple change - can you look at doing it?

Should just be adding script_timeout to this factory http://hg.mozilla.org/build/buildbotcustom/file/tip/process/release.py#l389
Assignee: nobody → armenzg
Priority: -- → P3
No longer blocks: hg-automation
Mass move of bugs to Release Automation component.
Component: Release Engineering → Release Engineering: Automation (Release Automation)
No longer blocks: hg-automation
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 628386
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.