Last Comment Bug 720848 - Trace through watchpoints from TraceRuntime
: Trace through watchpoints from TraceRuntime
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Bill McCloskey (:billm)
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-24 14:44 PST by Bill McCloskey (:billm)
Modified: 2012-01-25 07:09 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (2.65 KB, patch)
2012-01-24 14:44 PST, Bill McCloskey (:billm)
jorendorff: review+
Details | Diff | Splinter Review

Description Bill McCloskey (:billm) 2012-01-24 14:44:20 PST
Created attachment 591279 [details] [diff] [review]
patch

Normally the way we deal with weak pointers from TraceRuntime is to just treat them as strong. I have some code in the write barrier verifier that depends on this. However, it looks like we violate this rule for watchpoints.

There may be more issues like this, but this is the one that was causing me trouble.
Comment 2 :Ms2ger (⌚ UTC+1/+2) 2012-01-25 07:09:13 PST
https://hg.mozilla.org/mozilla-central/rev/df684ea711fc

Note You need to log in before you can comment on or make changes to this bug.