install window pops under when drag xpi onto addon manager tab

RESOLVED INVALID

Status

()

Toolkit
Add-ons Manager
RESOLVED INVALID
6 years ago
a year ago

People

(Reporter: noitidart, Unassigned)

Tracking

9 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Open the folder that has the xpi. Place it over your firefox browser which has the addon manager tab focused. Then drag the xpi to it.


Actual results:

software installation window was not noticed because it pops under. also in the error console it shows error:
Error: win is null
Source File: chrome://browser/content/browser.js
Line: 4094

I actually tested today and it seemed to pop up and over the windows folder. But when i drag it over a normal tab it seems to just pop up but not focus the software installation popup.



Expected results:

software installation should have popped over, possible should have focused the firefox browser, needs to be consistent. "win is null" error should be fixed

Updated

6 years ago
Duplicate of this bug: 720660

Updated

4 years ago
See Also: → bug 691389

Updated

4 years ago
Component: Untriaged → Add-ons Manager
Product: Firefox → Toolkit

Comment 2

4 years ago
I feel the design may be a feature that allows users to drag multiple XPI file one by one, and then to confirm these modal dialog.
This scenario can no longer be encountered starting with Firefox 40.0 due to the new add-on installation flow via doorhangers. 


Based on the this I am closing this bug as Invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.