Whenever Mozilla crashes, it kills X also

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: hhg, Assigned: asa)

Tracking

({relnote})

Trunk
x86
Linux
relnote

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 i686)
BuildID:    2001021503

Whenever Mozilla crashes (no matter why), it also kills X. Suddenly the Xserver
just crashes. Dunno if I can describe it any different without any help..

Reproducible: Always
Steps to Reproduce:
1. Start Mozilla
2. Surf around
3. Crash
4. Count to 10 'cause you lost all your work..

Actual Results:  Everything dies.

Expected Results:  Crashed and terminated instead, like normal programs do
(well, except for the obvious "stayed alive"-step.)

kernel 2.4.2. Glibc 2.1  Mandrake 7.1/7.2/different upgrades and packages,
X4.0.2 compiled with Render-support.

Comment 1

18 years ago
i just built on LM 7.1 XFree 4.0.1 with a nvidia geforce2 mx and I can't see
this. Not a blocker, as this seems to be specific to your setup.
Severity: blocker → critical

Comment 2

18 years ago
also, could you try a newer build? Can you reproduce this always?
(Reporter)

Comment 3

18 years ago
Yes. It always kills X when it dies. I have yet to experience that it does not,
and I have tested it for quite a while. Are there X-logs that might help you
track it, or any other info? I'd be happy to give you all availible info, but I
don't know what could be helpful in this case.

Comment 4

18 years ago
can not be reproduced here with a quite similar config (its a Suse, but the rest
is the same, except I am using the pre build XFree4.02). 

Can you start mozilla under the control of a debugger?
./mozilla -g
If we are lucky, the debugger prevents the crashing of X. Do a "where" and put
the results in here.

Since it looks like you compiled your copy of XFree yourself, this might be the
culprit. Did you use any exotic optimizations or other options when compiling
it? Which compiler did you use, something beta like everything above 2.95.2 or a
pgcc? Did you compile Mozilla yourself?
(Reporter)

Comment 5

18 years ago
./mozilla -g

took me a while to figure out what to do next :)

run
continue (plenty of times)

Trying to get mozilla to crash, and (not like it was a surprise) at
www.microsoft.com it crashes, and BOOM. Pitch black. gdb dies.

tried again with screen ./mozilla -g and detatching before going to
www.microsoft.com.

This time 'where' says this (although I doubt this is of any use to you
(unfortynately):

(gdb) where
#0  0x4025e17e in ?? ()
#1  0x401c21a0 in ?? ()
#2  0x401c2449 in ?? ()
#3  0x401a475c in ?? ()
#4  0x401a489c in ?? ()
#5  0x400cb669 in ?? ()
#6  0x400cb742 in ?? ()
#7  0x400cc133 in ?? ()
#8  0x400cbc54 in ?? ()
#9  0x408ccde1 in ?? ()
#10 0x408cb6cf in ?? ()
#11 0x40915081 in ?? ()
#12 0x409157db in ?? ()
#13 0x400db021 in ?? ()
#14 0x400cd571 in ?? ()
#15 0x400c9043 in ?? ()
#16 0x400c8f66 in ?? ()
#17 0x400c9d29 in ?? ()
#18 0x40496dbf in ?? ()
#19 0x40496b7d in ?? ()
#20 0x406354ba in ?? ()
#21 0x406369f6 in ?? ()
#22 0x40636fb1 in ?? ()
---Type <return> to continue, or q <return> to quit---
#23 0x40637129 in ?? ()
#24 0x4056155a in ?? ()
#25 0x404972ac in ?? ()
#26 0x404403ba in ?? ()
#27 0x804dd55 in JS_PushArguments ()
#28 0x804e595 in JS_PushArguments ()
#29 0x40257cbe in ?? ()
(gdb) where
#0  0x4025e17e in ?? ()
#1  0x401c21a0 in ?? ()
#2  0x401c2449 in ?? ()
#3  0x401a475c in ?? ()
#4  0x401a489c in ?? ()
#5  0x400cb669 in ?? ()
#6  0x400cb742 in ?? ()
#7  0x400cc133 in ?? ()
#8  0x400cbc54 in ?? ()
#9  0x408ccde1 in ?? ()
#10 0x408cb6cf in ?? ()
#11 0x40915081 in ?? ()
#12 0x409157db in ?? ()
#13 0x400db021 in ?? ()
#14 0x400cd571 in ?? ()
#15 0x400c9043 in ?? ()
#16 0x400c8f66 in ?? ()
#17 0x400c9d29 in ?? ()
#18 0x40496dbf in ?? ()
#19 0x40496b7d in ?? ()
#20 0x406354ba in ?? ()
#21 0x406369f6 in ?? ()
#22 0x40636fb1 in ?? ()
---Type <return> to continue, or q <return> to quit---
#23 0x40637129 in ?? ()
#24 0x4056155a in ?? ()
#25 0x404972ac in ?? ()
#26 0x404403ba in ?? ()
#27 0x804dd55 in JS_PushArguments ()
#28 0x804e595 in JS_PushArguments ()
#29 0x40257cbe in ?? ()
(gdb) 

Strangely enough, when I try to close gdb again, it says that the program i
sstill running, I dunno why.

where full just said thet it had no symbol-map availible :(

X was compiled with 

make World

and 

[hhg@hhg hhg]$ gcc --version
2.95.3
[hhg@hhg hhg]$ 

I downloaded mozilla from ftp.mozilla.org, it's the 0.8-package.

Comment 6

18 years ago
This may be "the other way around" - X crashing, taking everything - including
mozilla - with it. If X crashes, it seems to primarily be an X bug. See comments
in bug 63477. You could try disable truetype fonts and see if X crashes then too.

Perhaps releated: There are cases where Mozilla tries to scale fonts too large
for X to handle, some bugs open on that is bug 71080 and bug 59355.
(Reporter)

Comment 7

18 years ago
After compiling X4.0.3 it seems like the bug is gone. It all works fine now.
Guess we can call it invalig or Worksformee.

Håvard.

Comment 8

18 years ago
Marking WORKSFORME as per reporters comments. Possible relnote (upgrade to XFree
4.0.3 can fix mozilla crashing problems??)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Keywords: relnote
Resolution: --- → WORKSFORME

Comment 9

18 years ago
CCing endico for possible release note comment.

Updated

18 years ago
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.