Link Mozilians and github for purpose of recognising contributors

VERIFIED DUPLICATE of bug 701740

Status

Participation Infrastructure
Phonebook
--
enhancement
VERIFIED DUPLICATE of bug 701740
6 years ago
6 years ago

People

(Reporter: zac, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
Here on the mozwebqa team we benefit from public contributors aswell but we don't have as great means for recognising them as immortalising them in about:credits. 

We'd like to do more for them and an idea we came up with (thanks Bebe and AlexLakatos) was to link their github account with Mozillians. We were inspired by this page ( https://github.com/mozilla/Addon-Tests/contributors ) which lists contributors. Some of them are mozilla staff and some contributors, but the page is hidden away in the github gui.

This led us to think that a user's Mozillians account could be linked to github and the github API ( http://developer.github.com/v3/ ) used to check which of Mozilla's projects that user has worked on.

On the user's Mozillians page we would list the the projects that the user has contributed to and perhaps some basic statistics, if they are not too judgemental.

It would help us consolidate and recognise a user's contribution under the mozilla domain.

Thanks.
Thanks for filing this bug! We've wanted to do this for awhile and are finalizing a plan to do so later on in the year. It'll be easier to track this from the 1st bug that has been filed on this same enhancement.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 701740

Updated

6 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Version: unspecified → other

Updated

6 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.