Switch to vertical layout only when the window width < 550px

RESOLVED FIXED in Firefox 11

Status

()

Firefox
Developer Tools: Style Editor
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: paul, Assigned: paul)

Tracking

Trunk
Firefox 12
x86
All
Points:
---

Firefox Tracking Flags

(firefox11 verified)

Details

(Whiteboard: [qa+][testday-20120203][qa!:11])

Attachments

(2 attachments)

(Assignee)

Description

6 years ago
To avoid some frustration when the window is large enough to get the horizontal view.
(Assignee)

Comment 1

6 years ago
Created attachment 591456 [details] [diff] [review]
patch v1
(Assignee)

Updated

6 years ago
Attachment #591456 - Flags: review?(cedricv)
(Assignee)

Updated

6 years ago
Attachment #591456 - Flags: review?(cedricv) → feedback?(cedricv)
(Assignee)

Updated

6 years ago
Whiteboard: [addToFirefox11]
(Assignee)

Updated

6 years ago
Attachment #591456 - Flags: review?(mihai.sucan)
Comment on attachment 591456 [details] [diff] [review]
patch v1

Review of attachment 591456 [details] [diff] [review]:
-----------------------------------------------------------------

Patch looks good. Thanks Paul!
Attachment #591456 - Flags: review?(mihai.sucan) → review+
Attachment #591456 - Flags: feedback?(cedricv) → feedback+
(Assignee)

Updated

6 years ago
Whiteboard: [addToFirefox11] → [land-in-fx-team][addToFirefox11]
(Assignee)

Updated

6 years ago
Assignee: nobody → paul
Status: NEW → ASSIGNED
(Assignee)

Comment 3

6 years ago
https://hg.mozilla.org/integration/fx-team/rev/f0f0451c75eb
Whiteboard: [land-in-fx-team][addToFirefox11] → [fixed-in-fx-team][addToFirefox11]
https://hg.mozilla.org/mozilla-central/rev/f0f0451c75eb
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team][addToFirefox11] → [addToFirefox11]
Target Milestone: --- → Firefox 12
(Assignee)

Comment 5

6 years ago
Comment on attachment 591456 [details] [diff] [review]
patch v1

[Approval Request Comment]
Regression caused by (bug #): Not a regression, new feature.
User impact if declined: Bad UX. The StyleEditor UI will constantly be reorganized on resize.
Testing completed (on m-c, etc.): on m-c.
Risk to taking this patch (and alternatives if risky): low. Only CSS.
Attachment #591456 - Flags: approval-mozilla-aurora?

Comment 6

6 years ago
Comment on attachment 591456 [details] [diff] [review]
patch v1

[Triage Comment]
Low risk fix in support of a new feature. Approved for Aurora.
Attachment #591456 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 7

6 years ago
Created attachment 592661 [details] [diff] [review]
Patch v1 - rebased for Aurora
(Assignee)

Comment 8

6 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/e1d6266b5a2c
status-firefox11: --- → fixed
Whiteboard: [addToFirefox11]
Whiteboard: [qa+]

Comment 9

6 years ago
Seems to work on Linux-x86_64 with
* 11.0b1 as opposed to Nightly 20120125.
* Aurora Gecko/20120202 Firefox/12.0a2 as opposed to Gecko/20120101 Firefox/11.0a2

However, on my system it means that the file list can be much larger than the editor while there is a lot of blank space. If the text was larger, even less of it would fit, and/or more horizontal scrolling would appear. Do the text sizes depend on anything, and if yes, what about deriving the width from them? See also bug 719457.
Whiteboard: [qa+] → [qa+][testday-20120203]
(Assignee)

Comment 10

6 years ago
(In reply to Aleksej [:Aleksej] from comment #9)
> Seems to work on Linux-x86_64 with
> * 11.0b1 as opposed to Nightly 20120125.
> * Aurora Gecko/20120202 Firefox/12.0a2 as opposed to Gecko/20120101
> Firefox/11.0a2
> 
> However, on my system it means that the file list can be much larger than
> the editor while there is a lot of blank space.

"blank space"?

> If the text was larger,

Which text?

> even less of it would fit, and/or more horizontal scrolling would appear. Do the
> text sizes depend on anything, and if yes, what about deriving the width
> from them? See also bug 719457.

Sorry - I am not sure to understand. Can you open a new bug with screenshots?

Comment 11

6 years ago
(In reply to Paul Rouget [:paul] from comment #10)
https://bugzilla.mozilla.org/show_bug.cgi?id=723909
https://bugzilla.mozilla.org/show_bug.cgi?id=723912
Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0) Gecko/20100101 Firefox/11.0
Mozilla/5.0 (X11; Linux x86_64; rv:11.0) Gecko/20100101 Firefox/11.0

Verified using Firefox 11 beta 1 on Win 7, Ubuntu 11.10 and Mac OS X 10.6 that the Style Editor switches to vertical only when the width  is < 550 px.
status-firefox11: fixed → verified
Whiteboard: [qa+][testday-20120203] → [qa+][testday-20120203][qa!:11]
You need to log in before you can comment on or make changes to this bug.