Off-line synchronization of lightning 1.2 with CalDav Zimbra

RESOLVED WORKSFORME

Status

Calendar
Provider: CalDAV
RESOLVED WORKSFORME
6 years ago
3 years ago

People

(Reporter: Florent Boucher, Unassigned)

Tracking

Lightning 1.2
x86
Windows XP

Details

(Whiteboard: [calconnect31])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

I am not connected on the network (ethernet card deactivated) but the on-line/off-line toggle button is still on the on-line position.


Actual results:

When I open thunderbird 10.0b2/lightning 1.2 my network calendar (CalDav Zimbra with cache activated) is shown as non accessible (that is normal). If I try to write a new event, then I have an error tell me that the calendar is not accessible and it is not possible to write a new event when disconnected.
I have to switch the toggle button to the off-line position to be able to write off-line an event.



Expected results:

I was thinking that as the calendar is not accessible (not connected on the network), the writing of a new event will be done on the local cache, whatever the position on-line or off-line of the button.
(Reporter)

Updated

6 years ago
OS: All → Windows XP
Hardware: All → x86
Do you get any error console messages? Also please enable calendar.debug.log and calendar.debug.log.verbose to get more messages.
(Reporter)

Comment 2

6 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #1)
> Do you get any error console messages? Also please enable calendar.debug.log
> and calendar.debug.log.verbose to get more messages.

The only error I have when the I am online with a disconected network is a popup windows telling me the following :
MODIFICATION_FAILED
Etat : 0x804a0304, La requête ne peut être traitée

No error in the console error of thunderbird.

How do you activate the calendar.debug.log?
Options > Advanced > General > Config Editor
(Reporter)

Comment 4

6 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #3)
> Options > Advanced > General > Config Editor

Here are the error messages I got when if I just try to create an event being in the online mode

CalDAV: itemUri.spec = https://agenda.univ-nantes.fr/dav/xxx/Calendar/xxxx.ics

Erreur : CalDAV: Unexpected status adding item to Florent Boucher Zimbra: 0x804a0304

BEGIN:VCALENDAR
PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN
VERSION:2.0
BEGIN:VTIMEZONE
TZID:Europe/Paris
X-LIC-LOCATION:Europe/Paris
BEGIN:DAYLIGHT
TZOFFSETFROM:+0100
TZOFFSETTO:+0200
TZNAME:CEST
DTSTART:19700329T020000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3
END:DAYLIGHT
BEGIN:STANDARD
TZOFFSETFROM:+0200
TZOFFSETTO:+0100
TZNAME:CET
DTSTART:19701025T030000
RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10
END:STANDARD
END:VTIMEZONE
BEGIN:VEVENT
CREATED:20120125T173446Z
LAST-MODIFIED:20120125T173446Z
DTSTAMP:20120125T173446Z
UID:5d4a2f8c-ebd1-4c77-88a8-0bdb8017b2fe
SUMMARY:Nouvel événement
DTSTART;TZID=Europe/Paris:20120125T151500
DTEND;TZID=Europe/Paris:20120125T163000
BEGIN:VALARM
ACTION:DISPLAY
TRIGGER;VALUE=DURATION:-PT10M
DESCRIPTION:Description par défaut Mozilla
END:VALARM
END:VEVENT
END:VCALENDAR

Avertissement : Une erreur est survenue lors de la lecture de données de l'agenda : Florent Boucher Zimbra. Cependant, l'erreur est certainement mineure ; le programme va donc essayer de poursuivre. Code d'erreur : DAV_PUT_ERROR. Description : Une erreur est survenue lors du stockage de l'élément sur le serveur.

Erreur : Une erreur est survenue lors de l'écriture sur l'agenda Florent Boucher Zimbra ! Code d'erreur : MODIFICATION_FAILED. Description : État : 0x804a0304, La requête ne peut pas être traitée.


Fichier Source : resource://calendar/modules/calUtils.jsm -> file:///C:/Users/Profile_Mozilla/Thunderbird/Florent/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calCalendarManager.js
Ligne : 1108
Component: Lightning Only → Provider: CalDAV
Whiteboard: [calconnect31]
We've done a lot of fixes since 2 years ago, do you think you could try again? Offline support is pretty reliable nowadays. Please post error log messages as before if you do. I'm closing this as WFM for now, we will reopen if its still an issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.