Move mozglue/linker/Util.h into mfbt

RESOLVED DUPLICATE of bug 718938

Status

()

Core
General
--
enhancement
RESOLVED DUPLICATE of bug 718938
6 years ago
6 years ago

People

(Reporter: Yoric, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

File mozglue/linker/Util.h contains a number of RAII utilities that should be generic enough to live in mfbt. Moving them there would allow us to use this code e.g. in jsapi, hence reducing somewhat our amount of boilerplate.
Created attachment 591472 [details] [diff] [review]
Moving mozglue/linker/Utils.h to mfbt/Auto.h

Attaching a candidate patch
Attachment #591472 - Flags: review?(jwalden+bmo)
Comment on attachment 591472 [details] [diff] [review]
Moving mozglue/linker/Utils.h to mfbt/Auto.h

This file uses stdint.h directly, make it use mozilla/StdInt.h
Attachment #591472 - Flags: review?(jwalden+bmo) → review-
Created attachment 591488 [details] [diff] [review]
Moving mozglue/linker/Utils.h to mfbt/Auto.h

Thanks, Ms2Ger
Attachment #591472 - Attachment is obsolete: true
Blocks: 720771
Attachment #591488 - Flags: review?(jwalden+bmo)
Component: General → MFBT
QA Contact: general → mfbt
Not all the things in mozglue/linker/Utils.h are meant to be generally available. AutoClean is, and I filed a bug for it already (bug 718938)
Attachment #591488 - Flags: review?(jwalden+bmo) → review-
(In reply to Mike Hommey [:glandium] from comment #4)
> Not all the things in mozglue/linker/Utils.h are meant to be generally
> available. AutoClean is, and I filed a bug for it already (bug 718938)

Ok, so what do you suggest?
I suggest doing bug 718938, and see what Jeff has to say about the AutoClean template and its Auto* children.
Most notably, I suspect we may need some operators added to the AutoClean template.
Ok, so closing this bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Component: MFBT → General
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 718938
You need to log in before you can comment on or make changes to this bug.