2010 audited financial statement

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: marilyn, Assigned: boozeniges)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Please add a new section in Mozilla Foundation documents "2010 filings and related documents"  Attached is the 2010 audited financial statement for Mozilla Foundation
Duplicate of this bug: 721048
(In reply to Marilyn from comment #0)
> Attached is the 2010 audited financial statement for
> Mozilla Foundation

Where?
(Reporter)

Comment 3

7 years ago
Created attachment 591482 [details]
2010 Audited Financial Statments for Mozilla Foundation

Here is the attachment.  I've added it three times now so I do not know why it gets lost

Comment 4

7 years ago
Assigning to Ross.  He recently got access to make these sorts of edits.
Assignee: nobody → ross
(Assignee)

Comment 5

7 years ago
Uploaded to live.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.