Last Comment Bug 721068 - update to latest graphite2 code from upstream
: update to latest graphite2 code from upstream
Status: RESOLVED FIXED
[gfx.relnote.13]
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Jonathan Kew (:jfkthame)
:
Mentors:
Depends on: 631479 721466
Blocks: 712120 712587 746975
  Show dependency treegraph
 
Reported: 2012-01-25 09:01 PST by Jonathan Kew (:jfkthame)
Modified: 2015-08-30 23:37 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
update gfx/graphite2 to upstream rev.907 (changeset 58cb0cd37bf2) (540.60 KB, patch)
2012-01-25 09:01 PST, Jonathan Kew (:jfkthame)
roc: review+
Details | Diff | Review

Description Jonathan Kew (:jfkthame) 2012-01-25 09:01:19 PST
Created attachment 591491 [details] [diff] [review]
update gfx/graphite2 to upstream rev.907 (changeset 58cb0cd37bf2)

We should take a graphite2 update to benefit from recent bugfixes. This is pretty much a drop-in replacement for what we currently have; there are no API changes, etc., that affect our integration, just a couple of Makefile changes due to revised #define's for compile-time options that we select.

John, not sure what kind of "review" you think this needs, being essentially just a new code drop; rubber-stamp?
Comment 1 Jonathan Kew (:jfkthame) 2012-01-25 09:04:18 PST
Btw, this is expected to fix the build warnings we've been seeing on Windows.
Comment 2 John Daggett (:jtd) 2012-01-25 12:28:55 PST
Jonathan, I won't have time to review this until later next week so if you think this needs to land before the merge, feel free to switch the review to roc if he has lots of free cycles. ;)
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2012-01-25 13:35:17 PST
Comment on attachment 591491 [details] [diff] [review]
update gfx/graphite2 to upstream rev.907 (changeset 58cb0cd37bf2)

Review of attachment 591491 [details] [diff] [review]:
-----------------------------------------------------------------

I'm happy to rubber-stamp this.
Comment 4 Jonathan Kew (:jfkthame) 2012-01-26 03:31:09 PST
Bumped to upstream rev 911:a697cecbaddd, and pushed to inbound, carrying forward rs=roc:
https://hg.mozilla.org/integration/mozilla-inbound/rev/3ea57c1351cc
Comment 5 Marco Bonardo [::mak] 2012-01-26 15:59:24 PST
https://hg.mozilla.org/mozilla-central/rev/3ea57c1351cc
Comment 6 Yuan Pengfei 2012-01-26 23:10:02 PST
VC2010 SP1 PGO build fails at json.cpp
I fix it by adding:
#include <stdio.h>
Comment 7 Jonathan Kew (:jfkthame) 2012-01-27 00:21:09 PST
(In reply to Yuan Pengfei from comment #6)
> VC2010 SP1 PGO build fails at json.cpp
> I fix it by adding:
> #include <stdio.h>

See bug 721466.

Note You need to log in before you can comment on or make changes to this bug.