If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Tilt] Controls are sometimes unintuitive (especially when panning via mouse/keyboard)

RESOLVED WONTFIX

Status

Firefox Graveyard
Developer Tools: 3D View
P2
normal
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: AlinT, Unassigned)

Tracking

12 Branch

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Steps to reproduce:
1.Load any page in FF 12. Ex: google.com
2.Inspect page and enter 3D view(Right click -> Inpect Element -> 3D View)
3.Positionate the page upside down facing backwards.
4.Move the page up and down using right click(or up & down buttons)

Expected results:
Page moves correctly.

Actual results:
Page moves in the opposite direction.
the arcball doesn't reorient itself based on your current orientation. This is currently working as-designed, though I can understand the confusion.
Whiteboard: [tilt]
OS: Windows 7 → All
Hardware: x86 → All
Let's turn this bug into something more general.
From an IRC talk: "the controls we have manipulate the orientation of the visualization, the controls I want put me in a spaceship flying around the visualization". An enhanced arcball and/or an alternate control system would be nice.
Summary: [Tilt] Page in 3D view doesn't move correctly using right click → [Tilt] Controls are sometimes unintuitive (especially when panning via mouse/keyboard)
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Created attachment 602642 [details] [diff] [review]
v1

Recycled from experiments in bug 731652. Panning works like it should, both via keyboard/mouse. Added Q and E as roll controls. You can't really roll with the mouse. Tests fail.
Attachment #602642 - Flags: feedback?(rcampbell)
not bad. It's an extra range of motion that could be helpful for positioning. The roll is fixed about the center origin again though so at extreme ends of the page, the effect is much more pronounced. i.e., less precise.
As discussed on IRC, actually making this work properly would require a significant refactoring effort, to distinguish between a "model" and a "camera" (basically they're respective matrix transformations) in Tilt. Since this doesn't directly concern this bug, filed bug 734038.
Depends on: 734038
Duplicate of this bug: 737406
Created attachment 611416 [details] [diff] [review]
v2

Played with this a bit during the weekend.
Attachment #602642 - Attachment is obsolete: true
Attachment #602642 - Flags: feedback?(rcampbell)
Attachment #611416 - Flags: feedback?(rcampbell)
Priority: -- → P2
New component triage. Filter on HORSE MASKS.
Component: Developer Tools → Developer Tools: 3D View
Whiteboard: [tilt]
Attachment #611416 - Flags: feedback?(rcampbell)
Filter on TILT QUODLIBET.
Assignee: vporof → nobody
Status: ASSIGNED → NEW

Comment 10

2 years ago
The 3D View has been removed in Firefox 47. Closing all bugs inside that component as the component will be moved to Firefox Graveyard.

Filter on #BYETHREEDVIEW.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.