Flash is unusable - VERY slow, halting

RESOLVED INVALID

Status

()

RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: donrhummy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Went to page with flash


Actual results:

1. It took about 10 seconds to recognize and load the flash
2. The video plays about 1-2 second s of video, then stops for 1-2 seconds all the way through

(This happens for every flash video)


Expected results:

It should have played at least as well as Flash does in the Dolphin browser.
(Reporter)

Comment 1

7 years ago
NOTE: This is Flash Beta (what version is that? Isn't that version 10? I don't see a version 10 in the options)
Thank you for the report.  Can you give us URLs in terms of which sites you visited please?
(Reporter)

Comment 3

7 years ago
It's any site with flash, but here's some:

1. http://www.pcpro.co.uk/news/372385/ubuntu-rips-up-drop-down-menus
(the flash is an embedded youtube video)

2. http://www.collegehumor.com/
Thanks for the information.  Which device/Android OS are you on please?
I noticed that I am getting an OOM with a Nexus S.  There definitely is something going on here:

01-30 11:27:54.359: W/GeckoMultiTileLayer(655): MultiTileLayer encountered complex dirty region
01-30 11:27:55.386: D/dalvikvm(655): GC_EXTERNAL_ALLOC freed 591K, 65% free 3404K/9479K, external 19511K/21559K, paused 23ms
01-30 11:27:55.398: E/dalvikvm-heap(655): 4194304-byte external allocation too large for this process.
01-30 11:27:55.425: E/GraphicsJNI(655): VM won't let us allocate 4194304 bytes
01-30 11:27:55.425: D/dalvikvm(655): GC_FOR_MALLOC freed 2K, 65% free 3402K/9479K, external 19511K/21559K, paused 17ms
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): Unable to create bitmap
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): java.lang.OutOfMemoryError: bitmap size exceeds VM budget
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): 	at android.graphics.Bitmap.nativeCreate(Native Method)
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): 	at android.graphics.Bitmap.createBitmap(Bitmap.java:477)
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): 	at org.mozilla.gecko.gfx.GeckoSoftwareLayerClient.getBitmap(GeckoSoftwareLayerClient.java:374)
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): 	at org.mozilla.gecko.GeckoApp.getAndProcessThumbnailForTab(GeckoApp.java:593)
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): 	at org.mozilla.gecko.GeckoApp$SessionSnapshotRunnable.run(GeckoApp.java:586)
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): 	at android.os.Handler.handleCallback(Handler.java:587)
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): 	at android.os.Handler.dispatchMessage(Handler.java:92)
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): 	at android.os.Looper.loop(Looper.java:123)
01-30 11:27:55.425: W/GeckoSoftwareLayerClient(655): 	at org.mozilla.gecko.GeckoAppShell$LooperThread.run(GeckoAppShell.java:185)
01-30 11:27:55.468: D/GeckoBrowserProvider(655): Calling update on URI: content://org.mozilla.fennec.db.browser/images?profile=default
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

7 years ago
(In reply to Naoki Hirata :nhirata from comment #4)
> Thanks for the information.  Which device/Android OS are you on please?

Samsung Galaxy Tab 10.1 (Android 3.2)
(In reply to donrhummy from comment #5)
> (In reply to Naoki Hirata :nhirata from comment #4)
> > Thanks for the information.  Which device/Android OS are you on please?
> 
> Samsung Galaxy Tab 10.1 (Android 3.2)

we don't support flash on honeycomb at all. Not sure what you're seeing, but it is not flash related.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

7 years ago
(In reply to Brad Lassey [:blassey] from comment #6)
> (In reply to donrhummy from comment #5)
> > (In reply to Naoki Hirata :nhirata from comment #4)
> > > Thanks for the information.  Which device/Android OS are you on please?
> > 
> > Samsung Galaxy Tab 10.1 (Android 3.2)
> 
> we don't support flash on honeycomb at all. Not sure what you're seeing, but
> it is not flash related.

Just to double check:

1. I'm using Firefox BETA

2. What happens is, it first shows the video area as a gray box saying I need a plug in and then after about 10 seconds it starts to load and the video starts showing up. (And it can't be HTML5 because a number of those sites do not do HTML5 video)
You need to log in before you can comment on or make changes to this bug.