Open Bug 72116 Opened 20 years ago Updated 8 years ago

Attachment information dialog to view/assign charset of attachment

Categories

(MailNews Core :: Internationalization, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

Future

People

(Reporter: nhottanscp, Unassigned)

References

Details

(Whiteboard: intl)

Currently, we are sending text/plain attachment with no charset specification.
Those are likely to be in a OS file system charset but we wants to avoid putting
a wrong charset.
So I am proposing to have a dialog when the user double clicks an attachment.
That may show information about the attachment like MIME type or transfer
encoding type. We can put a charset information there and let the user to change it.

The options would be "none" as a default, "file system charset", or "choose from
the list".
Status: NEW → ASSIGNED
This can be merged into bug 66915.
Is there a bug to use the system default charset 
and insert that value into the charset parameter?
If not, we can use this bug for that and leave the
UI part to the other bug. 
I was thinking to provide the option of using file system charset as part of the
UI. Or is it better to separate it as a global preference?
Target Milestone: --- → Future
*** Bug 166606 has been marked as a duplicate of this bug. ***
See also bug 192262.
Severity: normal → enhancement
I think it'd be better as an option in the attachment right-click menu. I seem
to recall that there is work being done on adding option to set the MIME type
and content-disposition from the right-click menu, so it would fit right in. I
would expect double-clicking to open the attachment (as a preview), if anything.
I agree about right-click vs. double-click; the context menu should provide a 
Properties item, bringing up a dialog from which all the settable parameters for 
the attachment could be changed. Again, ref bug 192262.
Product: MailNews → Core
I also think that a charset option for attachments would be great. Mozilla/Seamonkey displays plain/text attachment right if the charset for this messages is ok. But it's a difficult hack to change the charset for attachments. (I sent the message with a text/plain attachment over a local sendmail server. In sendmail's queue I edit the message, change the charset and run sendmail's queue.)
Product: Core → MailNews Core
QA Contact: ji → i18n
Assignee: nhottanscp → nobody
Status: ASSIGNED → NEW
Whiteboard: intl
You need to log in before you can comment on or make changes to this bug.