Use Tabs.selectTab to select a new tab instead of sending a Tab:Selected message to gecko

VERIFIED FIXED in Firefox 11

Status

()

Firefox for Android
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Margaret, Assigned: Margaret)

Tracking

Trunk
Firefox 12
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 fixed, firefox12 fixed, firefox18 verified)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
Created attachment 591611 [details] [diff] [review]
patch

This should have been in the patch for bug 719493.
Attachment #591611 - Flags: review?(mbrubeck)
(Assignee)

Updated

5 years ago
Assignee: nobody → margaret.leibovic
Attachment #591611 - Flags: review?(mbrubeck) → review+
(Assignee)

Comment 1

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/282874267028

Comment 2

5 years ago
https://hg.mozilla.org/mozilla-central/rev/282874267028
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 12
Duplicate of this bug: 721364
(Assignee)

Comment 4

5 years ago
Comment on attachment 591611 [details] [diff] [review]
patch

[Approval Request Comment]
This is a follow-up that should have been part of bug 719493, which has aurora approval. Without this patch, tab switching is broken when trying to load a url that already exists in a tab.
Attachment #591611 - Flags: approval-mozilla-aurora?

Comment 5

5 years ago
Comment on attachment 591611 [details] [diff] [review]
patch

[Triage Comment]
Approved for Aurora.
Attachment #591611 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 6

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/230a7bf9aee6
status-firefox11: --- → fixed
status-firefox12: --- → fixed
This issue is fixed on the latest Nightly build. Closing bug as verified fixed on:

Firefox 18.0a1 (2012-09-12)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → VERIFIED
status-firefox18: --- → verified
You need to log in before you can comment on or make changes to this bug.