Last Comment Bug 721249 - Tab-bar buttons are slightly too small
: Tab-bar buttons are slightly too small
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Theme (show other bugs)
: Trunk
: x86_64 Windows 7
: -- trivial (vote)
: Thunderbird 13.0
Assigned To: Richard Marti (:Paenglab)
:
:
Mentors:
Depends on:
Blocks: 715495
  Show dependency treegraph
 
Reported: 2012-01-25 15:53 PST by Jim Porter (:squib)
Modified: 2012-02-21 07:49 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
The bug in action (8.31 KB, image/png)
2012-01-25 15:53 PST, Jim Porter (:squib)
no flags Details
patch (4.49 KB, patch)
2012-01-29 04:48 PST, Richard Marti (:Paenglab)
bugs: review+
bugs: ui‑review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Jim Porter (:squib) 2012-01-25 15:53:15 PST
Created attachment 591644 [details]
The bug in action

Compared to Firefox, the buttons on the tab bar are slightly too small:

1) There's a top margin that makes them shorter than they should be
2) There's a 1px gap between the bottom of the hover gradient and the tab bar (see attached screenshot)
Comment 1 Richard Marti (:Paenglab) 2012-01-29 04:48:19 PST
Created attachment 592489 [details] [diff] [review]
patch

This patch removes the 3px top-margins. Additionally I made the tabs the same height as Firefox (27px instead of 26px) and cleaned the files from remnants of pre tabs-on-top time.
I moved the #print-preview-toolbar definition from primaryToolbar-aero.css to messenger-aero.css because it wasn't used there.
On every file I touched I removed the 'all and' from the media queries (see Bug 713822).
Comment 2 Andreas Nilsson (:andreasn) 2012-01-31 08:32:12 PST
Comment on attachment 592489 [details] [diff] [review]
patch

Excellent!
Comment 3 Andreas Nilsson (:andreasn) 2012-02-16 17:08:17 PST
Comment on attachment 592489 [details] [diff] [review]
patch

And code looks good too.
Comment 4 Richard Marti (:Paenglab) 2012-02-17 00:05:25 PST
Comment on attachment 592489 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 715495 which is in TB 12
User impact if declined: No
Testing completed (on c-c, etc.): No testing, only review
Risk to taking this patch (and alternatives if risky): Should have no risk, it's only css
Comment 5 Mark Banner (:standard8) 2012-02-21 07:35:40 PST
Checked in: http://hg.mozilla.org/comm-central/rev/a6e02542cfd7
Comment 6 Mark Banner (:standard8) 2012-02-21 07:49:29 PST
Checked in:

http://hg.mozilla.org/releases/comm-aurora/rev/96355948daf9

Note You need to log in before you can comment on or make changes to this bug.