In fullscreen mode, when auto-hidden toolbars are shown, entire screen shifts downward.

RESOLVED DUPLICATE of bug 470534

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 470534
6 years ago
6 years ago

People

(Reporter: Caitlin, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
I'm sure this is a duplicate bug, because I can't imagine that I'm the first to complain about this behaviour, but I can't find any bugs that specifically addresses this! 

I'm using Firefox 10.0b5 in Windows Vista, but I've seen the behaviour numerous times with different versions of both Firefox and Windows (not sure about other OS's).

FYI, I'm not quite sure what the correct term is for what I'm calling the "browsing frame". I think it's pretty obvious, but if you're uncertain, it's the hbox node with the id "browser" (i.e., hbox#browser).

=====Steps to Reproduce=====
1. Ensure browser.fullscreen.autohide=true and browser.fullscreen.animateUp=0 or 2. Enter full-screen mode via F11 or Menu -> Full Screen
3. Move cursor to top of screen to "show" toolbars.

What happens: toolbars show up and force the browsing frame downward.

Expected behaviour: toolbars should be an overlay on top of the browsing frame. For the correct implementation, try entering full-screen mode in IE (I have IE8, but it should work in all versions >= 7).

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470534
You need to log in before you can comment on or make changes to this bug.