Closed Bug 721359 Opened 9 years ago Closed 9 years ago

Panning issues for Google Maps Classic

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 603008

People

(Reporter: paul.feher, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Nightly: Fennec/12.0a1(2012-01-26)
Aurora: Fennec/11.0a2(2012-01-25)
HTC Desire Z (Android 2.3)

   1. Launch Fennec
   2. Browse to Google Maps - classic version.
   3. Touch the map section and pan around.


Actual results:

The entire webpage pans.




Expected results:

The map section pans without panning the entire webpage.

NOTE: An scrollbar should not be displayed on the web page when the map section is paned.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Bug 603008 just landed touch-events as of last evening. If you're testing on today's Nightly, it still doesn't work?
Blocks: 603008
OS: Windows XP → Android
Hardware: x86 → ARM
The bug was found on today's Nightly. 

Nightly: Fennec/12.0a1(2012-01-26)
Touch events are disabled by default for now:
https://wiki.mozilla.org/Mobile/Notes/25-Jan-2012#WesJ

You can test them in Nightly by enabling the "dom.w3c_touch_events.enabled" pref.
I've tested with "dom.w3c_touch_events.enabled" pref. enebled on:

Fennec/12.0a1 (2012-01-26)
Devices: HTC Desire Z 
OS: Android 2.3

It seems that it's not reproducible anymore.

I will keep the bug open until the pref. "dom.w3c_touch_events.enabled" will be enabled by defaul.
Paul, you see this problem on the http://maps.google.com site?
Before bug 603008 landed, this would work correctly?

In that case, this seems to be a valid bug. When the "dom.w3c_touch_events.enabled" is disabled, it should just work as before the touch events patch landed.
I've tested on an previously Nightly version, before bug 603008 landed.

Fennec/12.0a1 (2012-01-24)
Devices: HTC Desire Z 
OS: Android 2.3

The bug is reproducible even with pref. "dom.w3c_touch_events.enabled" enabled by default.
Ok, so before bug 603008 landed, there was already a pref called "dom.w3c_touch_events.enabled" that was set to true by default? I've asked a question about this in bug 603008, because that seemed odd.

However, since this didn't work before the patch for bug 603008 landed, it means there is no bug here. The "dom.w3c_touch_events.enabled=false" pref should actually guarantees this issue exists, then.
TLDR: Yes. The pref was around in XUL Fennec. It was carried over to native even though we dropped our touch events support. Its now being respected in Native Fennec.

In bug 719309 I hooked up the pref in our widget code (its also used in nsDOMEvents.cpp or something like that), so in reality its preventing touch events in two places right now. That's required because, even if we prevent sending touch events in nsPresShell.cpp or somewhere, our java code has some special paths we also wanted to avoid (the ones that are causing the current touch events bugs).
This will become automatically fixed when the "dom.w3c_touch_events.enabled" pref is set to true by default.
Let's keep this open. I am duping to bug 603008
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 603008
I'm not sure what is meant with comment 10. By duping it, you're closing this bug, no?
You need to log in before you can comment on or make changes to this bug.