Last Comment Bug 721389 - New Tab Page doesn't retain zoom level
: New Tab Page doesn't retain zoom level
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: 12 Branch
: All All
: -- normal (vote)
: Firefox 15
Assigned To: Bellindira Castillo [:bellindira]
:
Mentors:
Depends on:
Blocks: 455553
  Show dependency treegraph
 
Reported: 2012-01-26 07:28 PST by Loic
Modified: 2012-05-04 07:25 PDT (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Removed isBlankPageURL condition and used about:blank instead of it because when the url is about:newtab the zoom level must be applied. (1.17 KB, patch)
2012-04-25 13:01 PDT, Bellindira Castillo [:bellindira]
ttaubert: review+
Details | Diff | Review

Description Loic 2012-01-26 07:28:24 PST
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120126 Firefox/12.0a1
Build ID: 20120126031113

Steps to reproduce:

1/ Open a 1st new tab and show the New Tab Page
2/ Modify zoom level (Ctrl+ or Ctrl-)
3/ Open a 2nd new tab


Actual results:

In the 2nd new tab, zoom level is set to default.
In the 1st new tab, modified zoom level reverts to default.

Of course, if you quit Firefox, the zoom level is not retained.


Expected results:

Zoom level for New Tab Page should be retained.
Comment 1 Jim Jeffery not reading bug-mail 1/2/11 2012-01-26 07:34:31 PST
Confirmed, setting to NEW
Comment 2 bogas04 2012-01-26 07:48:16 PST
It should not zoom at all in my opinion ...
Comment 3 Dão Gottwald [:dao] 2012-01-26 08:05:14 PST
Would you care to share some reasoning for this opinion? :)
Comment 4 bogas04 2012-01-26 08:53:25 PST
If Bug 699362 is to be fixed , clearly it is expected to act how the addon manager acts , which thus doesn't allow you to zoom in.

Besides that , although we can provide option to increase thumbnail size , an user won't like to see a messy new tab with zoomed in thumbnails and scroll bars to pan it. Instead , a sober list with thumbnails should be presented which makes it easy to choose desired "predicted" page.

New Tab Page is not a webpage which requires "close inspection" etc...
Comment 5 Dão Gottwald [:dao] 2012-01-26 10:12:19 PST
Zooming is useful for visually impaired people. This has nothing to do with close inspection.
Comment 6 bogas04 2012-01-26 10:17:29 PST
Of course , for that zooming the page makes lesser sense than zooming thumbnail sizes , just like Opera and Safari ... 

Well that's just my opinion :|
Comment 7 Bellindira Castillo [:bellindira] 2012-04-25 13:01:28 PDT
Created attachment 618408 [details] [diff] [review]
Removed isBlankPageURL condition and used about:blank instead of it because when the url is about:newtab the zoom level must be applied.
Comment 8 Tim Taubert [:ttaubert] 2012-04-26 11:48:26 PDT
Comment on attachment 618408 [details] [diff] [review]
Removed isBlankPageURL condition and used about:blank instead of it because when the url is about:newtab the zoom level must be applied.

Review of attachment 618408 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks! I'm going to land this later today.
Comment 9 Tim Taubert [:ttaubert] 2012-04-26 12:18:45 PDT
https://hg.mozilla.org/integration/fx-team/rev/9075fd99c34e
Comment 10 Tim Taubert [:ttaubert] 2012-04-27 05:54:11 PDT
https://hg.mozilla.org/mozilla-central/rev/9075fd99c34e
Comment 11 :Ehsan Akhgari (out sick) 2012-05-02 13:26:26 PDT
This patch was in a range which caused a Ts regression, so I backed out the whole range:

https://hg.mozilla.org/mozilla-central/rev/24a6a53c714a

Please reland after investigating and fixing the regression.
Comment 12 Tim Taubert [:ttaubert] 2012-05-02 17:14:09 PDT
Relanded because this is unlikely to be the cause of the Ts regression. We'll watch the graphs closely though.

https://hg.mozilla.org/integration/fx-team/rev/a284072ba169
Comment 13 Tim Taubert [:ttaubert] 2012-05-04 07:25:16 PDT
https://hg.mozilla.org/mozilla-central/rev/a284072ba169

Note You need to log in before you can comment on or make changes to this bug.