Last Comment Bug 721442 - [New Tab Page] Display the URL of the page on mouseover of thumbnails on about:newtab
: [New Tab Page] Display the URL of the page on mouseover of thumbnails on abou...
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Tabbed Browser (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Firefox 14
Assigned To: Tim Taubert [:ttaubert]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-26 10:15 PST by B.J. Herbison
Modified: 2012-04-14 02:45 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (1.08 KB, patch)
2012-04-11 05:49 PDT, Tim Taubert [:ttaubert]
dietrich: review+
Details | Diff | Splinter Review

Description B.J. Herbison 2012-01-26 10:15:02 PST
Among the sites I visit regularly are our product site, the staging site for new releases, our QA installation, and my private build of our product. All have the same appearance, and three of the four have the same title.

As it currently stands, the three sites with the same title are identical on the new tab page. (They aren't all currently shown, but I can't tell which are and which aren't without clicking.)

It would be useful if the URL of each page was displayed when when I mouseover a thumbnail on about:newtab.
Comment 1 Liam Davis 2012-02-13 19:16:45 PST
If you've already moused over the thumbnail the URL is visible in the standard link location bar. 

Further, I'm not sure how well it would fit with the thumbnails the current size. The URL would either get heavily truncated to the point of being largely useless (e.g something like "http://g..." or just "google.c..." for google which wouldn't be very useful for multiple sites on the same domain) or obscure the thumbnail significantly.

While I can certainly see how knowing the URL would be useful, there are ways of seeing the thumbnails URL without adding anything to the page as it currently stands.
Comment 2 Tim Taubert [:ttaubert] 2012-02-14 00:38:10 PST

*** This bug has been marked as a duplicate of bug 717110 ***
Comment 3 Tim Taubert [:ttaubert] 2012-02-14 00:40:00 PST
Oops, this one is about displaying the URLs, not the titles. Reopening.
Comment 4 Tim Taubert [:ttaubert] 2012-04-11 05:49:50 PDT
Created attachment 613959 [details] [diff] [review]
patch v1

Adding the site's url to the tooltips so that they are the same as when hovering places menuitems:

reddit: the front page of the internet
http://www.reddit.com/
Comment 5 Dietrich Ayala (:dietrich) 2012-04-12 17:12:37 PDT
Comment on attachment 613959 [details] [diff] [review]
patch v1

Review of attachment 613959 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with a test to verify attribute contains expected values for both no-title and has-title scenarios.
Comment 6 Tim Taubert [:ttaubert] 2012-04-13 15:45:39 PDT
Test added.

https://hg.mozilla.org/integration/fx-team/rev/b79c787bc18b
Comment 7 Tim Taubert [:ttaubert] 2012-04-14 02:45:21 PDT
https://hg.mozilla.org/mozilla-central/rev/b79c787bc18b

Note You need to log in before you can comment on or make changes to this bug.