Closed Bug 721640 Opened 10 years ago Closed 9 years ago

Perf: slowness in load of about:config

Categories

(Firefox for Android Graveyard :: General, defect, P4)

12 Branch
ARM
Android
defect

Tracking

(firefox12 affected, firefox14 fixed, firefox15 verified, firefox16 verified, blocking-fennec1.0 -, fennec-)

RESOLVED FIXED
Firefox 16
Tracking Status
firefox12 --- affected
firefox14 --- fixed
firefox15 --- verified
firefox16 --- verified
blocking-fennec1.0 --- -
fennec - ---

People

(Reporter: nhirata, Assigned: bnicholson)

References

Details

(Keywords: perf, Whiteboard: [has-regression-range])

Attachments

(2 files)

1. go to about:config

Expected: config will load fairly quickly
Actual: white screen and have to wait about 2 to 5 seconds

Note: 1/26/2012 build, Galaxy S Captivate, 2.2
cc'ing margaret
tracking-fennec: --- → -
Priority: -- → P4
This is a dead-simple way to make the about:config page render faster.  It limits the number of displayed items, and shows a message to refine your search if more items are found.
Adding Brian, since he was also playing around with improving about:config.
Duplicate of this bug: 749584
Duplicate of this bug: 754536
Not a release blocker.
blocking-fennec1.0: --- → -
Duplicate of this bug: 756932
Attached patch patchSplinter Review
This has been annoying me recently, so here's a simple patch that shows no entries when the filter is empty.
Attachment #630762 - Flags: review?(mark.finkle)
Comment on attachment 630762 [details] [diff] [review]
patch

This should be OK since we have a "Search Settings" placeholder string in the editbox, giving the user a hint as to what to do.
Attachment #630762 - Flags: review?(mark.finkle) → review+
Comment on attachment 630762 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: about:config takes several (10-15) seconds to load; gecko is frozen during this period
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): very low risk
String or UUID changes made by this patch: none
Attachment #630762 - Flags: approval-mozilla-beta?
Attachment #630762 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/d95dca51a833

(Merged by Ed Morley)
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 16
Attachment #630762 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Comment on attachment 630762 [details] [diff] [review]
patch

[Triage Comment]
Approving low-risk fix for beta, but please only land on tip of mozilla-beta (this will go out in Fennec 14.0.1)
Attachment #630762 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
There are no entries displayed when there is no search string entered. Once the user searches for a setting the results are displayed in a timely manner. 

Tested on:
Nightly 16.0a1 2012-06-19/ Aurora 15.0a2 2012-06-19
HTC Desire
Android 2.2

Patch has not made it in Firefox Mobile 14 Beta 7. Leaving the issue open for verification on Beta 8.
The patch has made it in Firefox 14 Beta 10. I'm leaving this resolved/fixed until the issues in Bug 764410 and Bug 770873 are fixed.
Depends on: 770873
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.