Content in div not visible

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
VERIFIED INVALID
17 years ago
17 years ago

People

(Reporter: srini, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows NT; DigExt)
BuildID:    Mozilla/5.0 (Windows; U; WinNT4.0; en-US; 0.9) Gecko/20010305

Content in a div which is contained in div and has style set to overflow auto 
and height 100% is not visible

Reproducible: Always
Steps to Reproduce:
check example below

<html>
<head>
 <title>Div Problem</title>
</head>
<body>
<div> 
<div style="overflow:auto;background-color: 
#DEDEC8;height:100%;">kdfjksdfjdlskfjdsklfdkfj</div>test
<div > 
</body>
</html>


Actual Results:  contents in inner div not visible

Expected Results:  content should be visible
Well, the outer div has auto height.  The inner div has 100% of that, so both
correctly end up with 0 height (try putting a border around the inner div to
demonstrate this).  overflow:scroll means that content that overflows the div is
not shown, and the scrollbar cannot be shown because it does not fit in a space
of height 0.  Giving the outer div a height (either implicitly by putting
content in it or explicitly in a style sheet) will of course get rid of all
these issues.

Over to style system for confirmation, but looks invalid to me..
Assignee: clayton → pierre
Component: HTML Element → Style System
OS: Windows NT → All
QA Contact: bsharma → ian

Comment 2

17 years ago
Marking INVALID as per bz's comments :)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Marking VERIFIED as per Keyser's comments :-)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.