AMO API doesn't return older versions of an add-on when they are compatible

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
3 years ago

People

(Reporter: jean.claveau, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:12.0a1) Gecko/20120127 Firefox/12.0a1
Build ID: 20120127031148

Steps to reproduce:

If you install the current version of thunderbird (9.0.1) and then look for lighting in the extension tab, you won't find it.


Actual results:

Lightning doesn't exists for tb 9.*.


Expected results:

Lightning 1.1 should be available.


This is because the lightning version for tb 9 is the 1.1 and the last one is the 1.2 wich works well only on tb 10+ (https://addons.mozilla.org/fr/thunderbird/addon/lightning/versions/).

But tb 10.0 is currently a beta!!

It looks like the extension manager doesn't search the last "compatible" version of an extension.

Comment 1

7 years ago
(In reply to Jean Claveau from comment #0)
Yes. I checked and it just checks the last released version and compares it with the Thunderbird version. If they are not compatible, the add-on doesn't appear.

Updated

7 years ago
Status: UNCONFIRMED → NEW
Component: General → Add-ons Manager
Ever confirmed: true
Product: Thunderbird → Toolkit
QA Contact: general → add-ons.manager
Version: 9 → 9 Branch
Component: Add-ons Manager → API
Product: Toolkit → addons.mozilla.org
QA Contact: add-ons.manager → api
Summary: Tb 9 doesn't find any available lightning because the last version is for tb 10 → AMO API doesn't return older versions of an add-on when they are compatible
Version: 9 Branch → unspecified
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.