If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

email filtering consistency

RESOLVED FIXED in Bugzilla 2.16

Status

()

Bugzilla
Email Notifications
P3
normal
RESOLVED FIXED
17 years ago
5 years ago

People

(Reporter: Stephan Niemz, Assigned: gerv)

Tracking

2.13
Bugzilla 2.16

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
As much as I appreciate the new email filtering options, I think they should
be consistent to avoid confusion, i.e. a checked box should always mean the
same, e.g. "send me mail" or "don't send me mail".

The first option is labeled "Do not email me bugs that I change" (negative)
while all the other ones are labeled "email me when ..." (positive).  So I
suggest reversing the first checkbox to read "Email me bugs that I change".

This way I could see by a quick glance whether I have any filtering options
active (anything not checked) or not.
(Reporter)

Updated

17 years ago
Blocks: 53044
Nominating for 2.12.  We've got enough other crap to fix with the email system 
before 2.12 can go out anyway, this will be an easy one to sneak in, and I agree, 
the current preference is backwards.
Target Milestone: --- → Bugzilla 2.12

Comment 2

17 years ago
Changing this to a positive could make it ambiguous IMO.

e.g. If you have
 "Email me bugs that I change" checked and "Keywords field changes" unchecked, 
and then you make a change only to the keywords field.

One option says you should have email, because it is a bug that you changed, 
but actually you wouldn't because none of your field-specific options triggered 
an email.

ISTM that the option is by nature 'negative' as it is disabling email that you 
would otherwise get, whereas all the other options enable email that you 
otherwise wouldn't get.

The option currently missing beside it "Do not email me any bugs" or "Disable 
all bug email" (Would be useful for vacations etc - Bug 66839) would also IMO 
seem more logical expressed in the negative.

Comment 3

17 years ago
I'm with Stephen on all counts.  Global negatives make more sense to me.  If we
were cool individuals, we could do something where we had "no mail" and "all
mail" (whatever verbage you like) buttons that would do the right things to all
the checkboxes to make it even more obvious.
Yeah, Stephen's right.  After I got to looking at it, I couldn't come up with a 
way to describe what that checkbox did in a positive way and still be accurate 
without involving a whole paragraph of text, and it wouldn't look real good at 
that point.

Should we just clarify the negative text to make it a little more clear?  Or 
leave it how it is?
(Assignee)

Comment 5

17 years ago
How about "Only email me reports of changes made by other people"? This does not 
reverse the meaning of the checkbox, yet could be considered clearer.

Gerv

Comment 6

17 years ago
Moving to 2.16, move back to 2.12 if you come up with effective wording.

Target Milestone: Bugzilla 2.12 → Bugzilla 2.16
Priority: -- → P3
Mass moving to new product Bugzilla...
Assignee: tara → jake
Component: Bugzilla → Email
Product: Webtools → Bugzilla
Version: Bugzilla 2.11 → 2.13

Comment 8

16 years ago
*** Bug 97846 has been marked as a duplicate of this bug. ***

Updated

16 years ago
No longer blocks: 53044
(Assignee)

Comment 9

16 years ago
Created attachment 53530 [details] [diff] [review]
Patch v.1
(Assignee)

Comment 10

16 years ago
Here's a patch with my wording. Looking for a= from Dave.

Gerv
Assignee: jake → gerv
Keywords: patch, review
Attachment #53530 - Flags: review+
Comment on attachment 53530 [details] [diff] [review]
Patch v.1

r=myk
Comment on attachment 53530 [details] [diff] [review]
Patch v.1

r= justdave
Attachment #53530 - Flags: review+
(Assignee)

Comment 13

16 years ago
/cvsroot/mozilla/webtools/bugzilla/userprefs.cgi,v  <--  userprefs.cgi
new revision: 1.23; previous revision: 1.22

Gerv
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.