Upgrade clang on the bots the old way

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: espindola, Assigned: rail)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 5 obsolete attachments)

Created attachment 592190 [details] [diff] [review]
update the clang that we build
Attachment #592190 - Flags: review?(rail)
(Assignee)

Updated

7 years ago
Attachment #592190 - Flags: review?(rail) → review+
Created attachment 592212 [details] [diff] [review]
upgrade the clang we build on linux
Assignee: nobody → respindola
Status: NEW → ASSIGNED
Attachment #592212 - Flags: review?(rail)
(Assignee)

Updated

7 years ago
Attachment #592212 - Flags: review?(rail) → review+
Created attachment 592289 [details] [diff] [review]
New version

Sorry, testing found a bug. I have fixed and this patch updates us to the new revision.
Attachment #592190 - Attachment is obsolete: true
Attachment #592289 - Flags: review?(rail)
Created attachment 592291 [details] [diff] [review]
new version on linux
Attachment #592212 - Attachment is obsolete: true
Attachment #592291 - Flags: review?(rail)
(Assignee)

Updated

7 years ago
Attachment #592289 - Flags: review?(rail) → review+
(Assignee)

Updated

7 years ago
Attachment #592291 - Flags: review?(rail) → review+
(Assignee)

Comment 6

7 years ago
Comment on attachment 592634 [details] [diff] [review]
pupet manifest

BTW, should we remove clang-3.0-r145194.moz0 (previous version)? We could remove it as a part of this puppet manifest or a separate change once you happy with this clan version.
Attachment #592634 - Flags: review?(rail) → review+
We can remove it now. What do I have to change on the patch to remove it?
(Assignee)

Comment 8

7 years ago
build on linux (32 bit) failed:

clang: /usr/src/redhat/SOURCES/llvm/lib/CodeGen/LiveInterval.cpp:246: llvm::LiveRange* llvm::LiveInterval::addRangeFrom(llvm::LiveRange, llvm::LiveRange*): Assertion `B->end <= Start && "Cannot overlap two LiveRanges with differing ValID's" " (did you def the same reg twice in a MachineInstr?)"' failed.
0  clang     0x0a3e4198
1  libc.so.6 0x009cb451 abort + 257
2  libc.so.6 0x009c324b __assert_fail + 251
3  clang     0x09eb2d11 llvm::LiveInterval::addRangeFrom(llvm::LiveRange, llvm::LiveRange*) + 311
Stack dump:
0.      Program arguments: /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage1/Release+Asserts/bin/clang -cc1 -triple i386-pc-linux-gnu -emit-obj -disable-free -main-file-name ProfileInfo.cpp -pic-level 2 -masm-verbose -mconstructor-aliases -target-cpu pentium4 -target-linker-version 2.17.50.0.6 -momit-leaf-frame-pointer -coverage-file /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/lib/Analysis/Release+Asserts/ProfileInfo.o -resource-dir /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage1/Release+Asserts/bin/../lib/clang/3.1 -dependency-file /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/lib/Analysis/Release+Asserts/ProfileInfo.d.tmp -MP -MT /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/lib/Analysis/Release+Asserts/ProfileInfo.o -MT /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/lib/Analysis/Release+Asserts/ProfileInfo.d -D _DEBUG -D _GNU_SOURCE -D __STDC_CONSTANT_MACROS -D __STDC_FORMAT_MACROS -D __STDC_LIMIT_MACROS -I /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/include -I /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/lib/Analysis -I /usr/src/redhat/SOURCES/llvm/include -I /usr/src/redhat/SOURCES/llvm/lib/Analysis -fmodule-cache-path /var/tmp/clang-module-cache -internal-isystem /tools/gcc-4.5-0moz3/include/c++/4.5.2/ -internal-isystem /tools/gcc-4.5-0moz3/include/c++/4.5.2//i686-pc-linux-gnu -internal-isystem /tools/gcc-4.5-0moz3/include/c++/4.5.2//backward -internal-isystem /usr/local/include -internal-isystem /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage1/Release+Asserts/bin/../lib/clang/3.1/include -internal-externc-isystem /include -internal-externc-isystem /usr/include -O3 -Woverloaded-virtual -Wcast-qual -Wno-long-long -Wall -W -Wno-unused-parameter -Wwrite-strings -pedantic -fconst-strings -fdeprecated-macro -fdebug-compilation-dir /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/lib/Analysis -ferror-limit 19 -fmessage-length 0 -fvisibility-inlines-hidden -mstackrealign -fno-rtti -fgnu-runtime -fobjc-runtime-has-arc -fobjc-runtime-has-weak -fobjc-fragile-abi -fdiagnostics-show-option -o /usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/lib/Analysis/Release+Asserts/ProfileInfo.o -x c++ /usr/src/redhat/SOURCES/llvm/lib/Analysis/ProfileInfo.cpp
1.      <eof> parser at end of file
2.      Code generation
3.      Running pass 'Function Pass Manager' on module '/usr/src/redhat/SOURCES/llvm/lib/Analysis/ProfileInfo.cpp'.
4.      Running pass 'Simple Register Coalescing' on function '@_ZN4llvm12ProfileInfoTINS_8FunctionENS_10BasicBlockEE20CalculateMissingEdgeEPKS2_RSt4pairIS5_S5_Eb'
clang: error: unable to execute command: Aborted
clang: error: clang frontend command failed due to signal (use -v to see invocation)
clang: note: diagnostic msg: Please submit a bug report to http://llvm.org/bugs/ and include command line arguments and all diagnostic information.
clang: note: diagnostic msg: Preprocessed source(s) and associated run script(s) are located at:
clang: note: diagnostic msg: /tmp/ProfileInfo-pIzIil.ii
clang: note: diagnostic msg: /tmp/ProfileInfo-pIzIil.sh
/bin/rm: cannot remove `/usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/lib/Analysis/Release+Asserts/ProfileInfo.d.tmp': No such file or directory
make[2]: *** [/usr/src/redhat/BUILD/clang-3.0-r149148.moz0/stage2/lib/Analysis/Release+Asserts/ProfileInfo.o] Error 1
64 bits worked?

I will try to install a centos5 VM to try to reproduce it, but I am in brussels at the moment, not sure if the wifi will handle it :-(
Do you have a centos 5 machine I can log in to? Probably can be any machine, not only one of the official bots.
(Assignee)

Comment 10

7 years ago
(In reply to Rafael Ávila de Espíndola (:espindola) from comment #9)
> 64 bits worked?

Yes. BTW, the previous version from this bug worked well, something changed between 149137 and 149148...
 
> Do you have a centos 5 machine I can log in to? Probably can be any machine,
> not only one of the official bots.

I don't have a centos machine, but you can borrow a bot, it shouldn't take long to get it, just file a bug. Sorry, I'm a little bit busy with releases, you'll get your bot faster if file a bug and the buildduty person handles it.
I was able to install a centos 5 32 bit in a VM and reproduce the problem. Debugging.
This was fixed by r149163. I will give it a try.
Created attachment 593410 [details] [diff] [review]
Use r149163 on linux.

OK if it bootstraps and bulids firefox?
Attachment #592291 - Attachment is obsolete: true
Attachment #593410 - Flags: review?(rail)
(Assignee)

Comment 14

7 years ago
Comment on attachment 593410 [details] [diff] [review]
Use r149163 on linux.

lgtm
Attachment #593410 - Flags: review?(rail) → review+
Created attachment 593412 [details] [diff] [review]
Use r149163 on os x
Attachment #592289 - Attachment is obsolete: true
Attachment #593412 - Flags: review?(rail)
(Assignee)

Updated

7 years ago
Attachment #593412 - Flags: review?(rail) → review+
Created attachment 593421 [details] [diff] [review]
puppet manifest for r149163
Attachment #592634 - Attachment is obsolete: true
Attachment #593421 - Flags: review?
(Assignee)

Comment 17

7 years ago
Comment on attachment 593421 [details] [diff] [review]
puppet manifest for r149163

I think you wanted to r? me :)
The patch looks good. I'll land it when we're ready to deploy.
Attachment #593421 - Flags: review? → review+
(Assignee)

Updated

7 years ago
Assignee: respindola → rail
Cool.  A quick status update.  I was able to build clang at that revision on OS X and use that to build the universal firefox dmg.

A bootstrap on a centos 5 32 bit is almost done.  A 64 bit just started. I will commit once I have firefox builds on both.
Both bootstraps finished. The mozilla builds are going fine, so I pushed the patches here:

https://hg.mozilla.org/build/rpm-sources/rev/375e5b96d2f9
http://hg.mozilla.org/build/braindump/rev/39423156622a
(Assignee)

Updated

7 years ago
Attachment #593410 - Flags: checked-in+
(Assignee)

Updated

7 years ago
Attachment #593412 - Flags: checked-in+
(Assignee)

Comment 21

7 years ago
Deployment started. However, give it a day to be deployed everywhere.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.