build failure with VS2010 due to stl_wrappers

RESOLVED WORKSFORME

Status

()

Core
XPCOM
RESOLVED WORKSFORME
7 years ago
4 years ago

People

(Reporter: jfkthame, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 592214 [details]
output of -showIncludes, prior to the patch from bug 721466

The compilation error reported in bug 721466 (and worked around with a hack there) appears to be caused by the stl_wrappers that we use around standard C++ headers.

Prior to the hack there (replacing <cstdio> with <stdio.h> in json.cpp, and thereby bypassing the stl_wrapper), running the compiler with the -showIncludes option produces the attached trace. Note that VS2010's <iosfwd> needs to include <cstdio> to define types such as fpos_t, but our wrapper interferes with this and leads to the reported failure.
(Reporter)

Updated

7 years ago
Blocks: 721466
I'm going to say that since we use VS2010 nowadays, this has been fixed.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.