All users were logged out of Bugzilla on October 13th, 2018

use increased MAX_BROKER_REFS on build/test master

RESOLVED DUPLICATE of bug 712244

Status

P3
critical
RESOLVED DUPLICATE of bug 712244
7 years ago
5 years ago

People

(Reporter: bhearsum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [buildmasters][capacity][buildbot])

We continue to hit the maximum number of builders per slave, particularly on the Linu xtest machines. We need to up the MAX_BROKER_REFS so this stops breaking things.

The tegras already use it, like this:
import twisted.spread.pb
twisted.spread.pb.MAX_BROKER_REFS = 2048

in the .tac files.

We need to test it to make sure it doesn't anything.

Comment 1

7 years ago
If we take the effort to bump this, we may want to choose something like 4096 or some other largish number that we don't foresee hitting for a long long time.
(Reporter)

Updated

7 years ago
Blocks: 722577
(In reply to Aki Sasaki [:aki] from comment #1)
> If we take the effort to bump this, we may want to choose something like
> 4096 or some other largish number that we don't foresee hitting for a long
> long time.

Is increasing the refs that high going to have other adverse affects?
Priority: -- → P3
Whiteboard: [buildmasters][capacity][buildbot]
The increase itself will not, but I don't know about the effects of using that many refs.  Most likely you will see further inordinate memory use and slowness.  I don't know if the underlying algorithms are O(N) (in which case quadrupling will only make things four times slower/bigger) or O(N^2) (which would make it sixteen times slower/bigger) or what.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 712244
No longer blocks: 723479
(Assignee)

Updated

5 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.