Recipient's copy of my sent emails show that I used multiple fonts, even though when composing the e-mail only one font was used.

RESOLVED DUPLICATE of bug 250539

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 250539
6 years ago
6 years ago

People

(Reporter: Cngevpxhaqrefpber, Unassigned)

Tracking

9 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Type an e-mail ("Compose emails in HTML format" is checked). My default font is Verdana.


Actual results:

In my email composition window in Thunderbird, the text in my emails are all always in one font.

However, when people respond to my e-mails, many times in their quote of my e-mail, I see that in the beginning of the email the font is Verdana, as it should be, but then in seemingly random positions in the quote, the font changes to a totally different one, such as Arial or Times New Roman -- even though it didn't appear this way in my composition window when I was composing the email.


Expected results:

The text in recipient's copy of my e-mail should be all in the same font, as it appeared in my composition window.

This has occurred for as long as I can remember, including the latest version (9.0.1).

Comment 1

6 years ago
(In reply to Cngevpxhaqrefpber from comment #0)
Can you BCC yourself when you send emails and check the email you receive?
(Reporter)

Comment 2

6 years ago
Will do!
(Reporter)

Comment 3

6 years ago
I was actually able to go back through my sent folder and find the problem. When I looked at the message sources of the e-mails in question (the ones that, when quoted by the person I was corresponding with, the font would change seemingly randomly in their reply) and I found that it looks something like this:

<font face="Verdana">Blah blah blah</font> ABCDEFG.

With "blah blah blah" being in the correct font, and ABCDEFG being in a different font, when shown in the quote, or viewing my sent folder from Gmail. When I view the e-mail in my sent folder in Thunderbird however, the e-mail looks just fine.

I'm not sure if this is relevant or not, but my Send Options / Text Format is set to "Send the message in both plain text and HTML".

Let me know if you need anything else.

Comment 4

6 years ago
(In reply to Cngevpxhaqrefpber from comment #3)
See bug 250539.
(Reporter)

Comment 5

6 years ago
Thanks, I didn't read the whole thread of comments, but comment 71 there seems to describe the issue I'm experiencing.

I tried clicking around at the end of the line and elsewhere in the e-mail composition window as he described and I was able to reproduce the problem. I'm not sure if that's the only thing that has caused the issue for me in the past, but it did just now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 250539
You need to log in before you can comment on or make changes to this bug.