Unresponsive script and crash

RESOLVED WORKSFORME

Status

()

P1
critical
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: bug.zilla, Unassigned)

Tracking

({crash, reproducible})

Trunk
ARM
Android
crash, reproducible
Points:
---

Firefox Tracking Flags

(blocking-fennec1.0 -)

Details

(Whiteboard: [native-crash], oom, URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Visited the following URL:
http://www.boston.com/bigpicture/2012/01/harbin_international_ice_and_s.html


Actual results:

Very slow loading, then the "unresponsive script" pop up appears and then a crash.
However, no option appears to report the crash to Mozilla.

Note that this URL works fine in the stock browser.


Expected results:

Correctly load the URL.

Comment 1

7 years ago
Which version do you use?
Can you provide the logcat (see https://market.android.com/details?id=org.jtb.alogcat)?
Severity: normal → critical
Keywords: crash
OS: Windows 7 → Android
Hardware: x86_64 → ARM
Whiteboard: [native-crash]
(Reporter)

Comment 2

7 years ago
I'm using version 12.0a1 (2012-01-28).

Do you get the same result?
Which device and Android version?
Can you also post a log cat?
(Reporter)

Comment 5

7 years ago
Created attachment 592875 [details]
aLogcat

I now no longer get the problem on that site (perhaps the latest Nightly fixed it) but I do still get it on another site.

I attach the log - thanks.
Which other site do you get the problem with? Which device are you using? Which Android version?
I noticed this in the logcat:
I/ActivityManager(  190): Low Memory: No more background processes.
(Reporter)

Comment 7

7 years ago
The site is www.philenews.com (please try it without any add ons or an edited hosts file that might prevent some ads from downloading)

Device: Samsung Galaxy S GT-I9000

Software: CM7
Created attachment 593682 [details]
logcat

http://goo.gl/keMiY; looks like an OOM issue.  I had the same thing occur with this web page, with the Nexus S Captivate  It's an uncaught OOM.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [native-crash] → [native-crash], oom
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 9

7 years ago
The crash on this site has indeed been resolved:
http://www.boston.com/bigpicture/2012/01/harbin_international_ice_and_s.html

But I'm still getting the same crash (with no option to report it) on this site:
www.philenews.com

Please have a look at the log here: https://bugzilla.mozilla.org/attachment.cgi?id=592875

By the way, it works fine on the stock browser.
Thanks
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
tracking-fennec: --- → ?

Updated

7 years ago
Priority: -- → P1

Updated

7 years ago
tracking-fennec: ? → ---
(Reporter)

Comment 10

7 years ago
An update to the above bug:

1. Disabling Flash on www.philenews.com now solves the problem.
With Flash enabled it still FCs

2. This site also crashes the whole device requiring a battery pull when I double tap to zoom into the text. Again disabling Flash solves it.

The site is: http://www.geek.com/articles/geek-pick/android-browser-beta-battle-chrome-vs-firefox-20120517/
Created attachment 625300 [details]
logcat 5-18-2012

(In reply to bug.zilla from comment #10)
> An update to the above bug:
> 
> 1. Disabling Flash on www.philenews.com now solves the problem.
> With Flash enabled it still FCs
> 
> 2. This site also crashes the whole device requiring a battery pull when I
> double tap to zoom into the text. Again disabling Flash solves it.
> 
> The site is:
> http://www.geek.com/articles/geek-pick/android-browser-beta-battle-chrome-vs-
> firefox-20120517/

I can also reproduce this on the Galaxy Nexus also, beta 1.   

STR: 
- loading the geek.com site and trying to pan up and down until screen locks up.
- no real helpful logcat, but attached anyway.

key notes:
- having flash enabled in firefox settings
- once screen freezes, content body is unresponsive, but you can still launch fennec preferences pane
** if you launch prefs pane, you'll see grayed out options like this:  http://i.imgur.com/XEaHG.png (i should file another bug here)

http://www.geek.com/articles/geek-pick/android-browser-beta-battle-chrome-vs-firefox-20120517/
probably could use a reduced testcase.
blocking-fennec1.0: --- → ?

Updated

7 years ago
Keywords: reproducible
blocking-fennec1.0: ? → -
(Reporter)

Comment 13

6 years ago
Hi, this is still happening on v. 17 of Nightly.

I don't think it's a Flash issue because it happens even when "Tap to play" is selected.

No option to submit a crash report is offered; it just FCs.
(Reporter)

Comment 14

6 years ago
Hi, this is still occurring on v. 18.
Very slow to load site philenews.com and request never completes.
(Reporter)

Comment 15

6 years ago
Now upgraded to CM9 but the issue persists on philenews.com
Can someone replicate?

Thanks.

Updated

6 years ago
Version: Firefox 12 → Trunk
(Reporter)

Comment 16

6 years ago
A couple of more where there are issues:

This one just kills Firefox. Works fine on stock. 
http://www.customcans.co.uk/blog/

This one takes a very long time to complete. Works fine on stock.
http://www.sigmalive.com/

Can someone replicate?
(In reply to bug.zilla from comment #16)
> This one just kills Firefox. Works fine on stock. 
> http://www.customcans.co.uk/blog/
> 

I can reproduce this. Seems like it eats up a lot of memory and then dies because Android decides it's had enough. This happens even on the Galaxy Nexus.

> This one takes a very long time to complete. Works fine on stock.
> http://www.sigmalive.com/

This one game me an unresponsive script warning, and even after stopping the script it took a while to finish.
(In reply to bug.zilla from comment #15)
> Now upgraded to CM9 but the issue persists on philenews.com
> Can someone replicate?

I can reproduce this on 18 but it seems fixed on 19 and up.
(Reporter)

Comment 19

6 years ago
One more to add: http://www.customcans.co.uk/blog/
Firefox crashes and exits with no option to send an error report.

Works fine in stock.
(Reporter)

Comment 20

6 years ago
Hi,

can anyone replicate this?
(Reporter)

Comment 21

6 years ago
Is anyone able to replicate the crash on this site:
http://www.customcans.co.uk/blog/
In comment 17 I said I could reproduce it.
(Reporter)

Comment 23

5 years ago
I will close this now, as it works on a Galaxy Note but note that on lower end devices it's still an issue.
The link is: http://www.customcans.co.uk/blog/
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.