FF forces information in form.

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
7 years ago
2 years ago

People

(Reporter: de.techno, Unassigned)

Tracking

8 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I discovered a bug wile filing a bug for Vuze.

Open up - 

https://jira.vuze.com/secure/Signup.jspa

For this bug to work, your FF should suggest a few usernames in the Username field.

Enter one of the usernames from one of what FF suggests, then switch to another field using <tab>.

Now try to edit the username field such that it has a different case from the suggested, e.g.

If FF suggests dE_logics, de_Logics you try and write de_logics, but FF reverts back to dE_logics until you delete all the suggestions using <delete>.
Mozilla/5.0 (X11; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0

Can't reproduce with the STR:
1. Add dE_logics and de_Logics to the username field (press enter so that the names are registered).
2. Reload the webpage.
3. Choose one of the usernames. 
4. Tab
5. Return to the username field. Write 'de_logics'
6. Press Tab.

The last name was remembered. Please correct me if I got the steps wrong.

Can you reproduce with a clean profile? 
http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Component: General → Layout: Form Controls
Product: Firefox → Core
QA Contact: general → layout.form-controls
(Reporter)

Comment 2

7 years ago
Apparently there's something wrong with my profile. The problem does as a different user.

Here, the history contains de_logics, and when I try to change it from de_logics to dE_logics and move to a new field, it reverts back to de_logics.

I'll try to disable the addons one by one and see.
(Reporter)

Comment 3

7 years ago
And the bug persists with all addons disabled.

I think it has to do something with the saved passwords. Some pointers will be great.

Comment 4

2 years ago
(In reply to dE from comment #3)
> And the bug persists with all addons disabled.

Was that in safe mode?
Does it happen today?
Flags: needinfo?(de.techno)
(Reporter)

Comment 5

2 years ago
That page doesn't exist anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(de.techno)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.