xpc_qsGetWrapperCache users in CustomQS_Canvas2D.h seem broken

RESOLVED DUPLICATE of bug 734668

Status

()

Core
XPConnect
RESOLVED DUPLICATE of bug 734668
6 years ago
5 years ago

People

(Reporter: Ms2ger, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
They have

nsCOMPtr<nsISupports> resultInterface;
...
qsObjectHelper helper(resultInterface,
                      xpc_qsGetWrapperCache(resultInterface))

and all we have in implementations is

xpc_qsGetWrapperCache(nsWrapperCache *cache) { return cache; }
xpc_qsGetWrapperCache(void *p) { return nsnull; }

so this just passes null to qsObjectHelper, right?
Yes.  Why is that a problem per se?  Do these objects actually inherit from nsWrapperCache?  If not, then passing null is the right thing to do.
(Reporter)

Comment 2

6 years ago
They don't inherit from nsWrapperCache, but why write null as xpc_qsGetWrapperCache(resultInterface) when you can write it as NULL?
Probably because it just expanded out codegened worker code...

I wouldn't worry too much about this; this stuff is on the short-list for new-bindings.
(Reporter)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 734668
You need to log in before you can comment on or make changes to this bug.