make package fails if --disable-tests (Fennec Native)

RESOLVED FIXED

Status

()

Core
Build Config
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: dougt, Assigned: dougt)

Tracking

({regression})

Trunk
All
Android
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Since the robocop landing, if you build with --disable-tests, make package will fail with the following:


java.io.FileNotFoundException: /Users/dougt/builds/mozilla-central/obj-fennec/mobile/android/installer/../../../dist/../build/mobile/robocop/robocop.ap_ does not exist
(Assignee)

Comment 1

6 years ago
Created attachment 592461 [details] [diff] [review]
patch v.1
Assignee: nobody → doug.turner
Attachment #592461 - Flags: review?(blassey.bugs)
Attachment #592461 - Flags: review?(blassey.bugs) → review+
Duplicate of this bug: 722172
thanks for the patch!
(In reply to Doug Turner (:dougt) from comment #1)
> Created attachment 592461 [details] [diff] [review]
> patch v.1

I verified this patch corrects the issue I reported in bug 722172.

Therefore I am carrying over the regression info form that patch.
Blocks: 719697
Keywords: regression
Summary: make package fails if --disable-tests → make package fails if --disable-tests (Fennec Native)
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/mozilla-central/rev/e33539a90ae2
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Attachment #592461 - Flags: approval-mozilla-aurora?
I haven't been marking all the robocop stuff apporval-mozilla-aurora.   This patch probably won't apply properly if landed on aurora.

Comment 7

6 years ago
Comment on attachment 592461 [details] [diff] [review]
patch v.1

[Triage Comment]
Based upon comment#6, please re-request when you're ready to land.
Attachment #592461 - Flags: approval-mozilla-aurora? → approval-mozilla-beta-
You need to log in before you can comment on or make changes to this bug.