crashes while printing when using gtk+ 2.24.9

RESOLVED WORKSFORME

Status

()

Core
Printing: Output
--
major
RESOLVED WORKSFORME
7 years ago
a year ago

People

(Reporter: Ionut Biru, Unassigned, NeedInfo)

Tracking

9 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 592480 [details]
gdb trace

This happens because now they set up correctly custom options, a feature or bug fix introduced in [1].

Discussion this issue upstream to the bug report mentioned in the commit lead to the conclusion that is a firefox/thunderbird issue rather than a gtk+ one.[2] In there you will find as well two PPDs that lead to a crash.

[1] http://git.gnome.org/browse/gtk+/commit/?h=gtk-2-24&id=8170436e61ea68c713d75ad374d22c3261be9203
[2] https://bugzilla.gnome.org/show_bug.cgi?id=543520#c41
Component: General → Printing: Output
Product: Firefox → Core
QA Contact: general → printing
The crash itself is a bug in CUPS/GTK+ and should be fixed there but we should of course not send garbage.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Yes that seems to be the issue here.

1.  cups has always crashed when you send custom fields not supported by the device.  a cups bug.

2.  gtk used to not properly send the custom data at all so avoided the issue.

So, yes we should not be sending unsupported custom fields to a device, but that should not cause a crash either.
Is this still an issue in recent Firefox / GTK versions?
Flags: needinfo?(biru.ionut)
Ionuț no longer sees this issue
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.