Last Comment Bug 722167 - Severe Graphics corruption
: Severe Graphics corruption
Status: RESOLVED FIXED
: regression
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Mac OS X
: -- major (vote)
: ---
Assigned To: Joe Drew (not getting mail)
:
Mentors:
: 722170 722177 722314 (view as bug list)
Depends on:
Blocks: 721467
  Show dependency treegraph
 
Reported: 2012-01-29 09:14 PST by Benoit Girard (:BenWa)
Modified: 2012-01-30 10:16 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Screenshot (37.10 KB, image/png)
2012-01-29 09:14 PST, Benoit Girard (:BenWa)
no flags Details
another screenshot (824.77 KB, image/png)
2012-01-29 10:20 PST, Byron Jones ‹:glob›
no flags Details

Description Benoit Girard (:BenWa) 2012-01-29 09:14:24 PST
Created attachment 592512 [details]
Screenshot

I'm seeing graphics corruption turn up in several page after updating to today's nightly.

The corruption occurs at the edge of the window when scrolling and stays until the page repaints so I bet it has to do with layer rotation.

I first saw this bug when visiting a google docs with comment, see screenshot for example.

Sample doc: https://docs.google.com/document/d/1dpt9CgJ8cbECqaQpW3HucSd0PO1GOd8R4hTUQffg2jg/edit
Comment 1 Byron Jones ‹:glob› 2012-01-29 10:20:54 PST
Created attachment 592520 [details]
another screenshot

i also see graphical corruption on latest nightly (osx), staying until a repaint.
Comment 2 Nickolay_Ponomarev 2012-01-29 10:34:59 PST
Unchecking "Use hardware acceleration when available" works around the problem for me (Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:12.0a1) Gecko/20120129 Firefox/12.0a1)
Comment 3 Joe Drew (not getting mail) 2012-01-29 10:49:24 PST
Is this only happening to people on 10.7? I can't reproduce on 10.6. :(

If I could reproduce I could bisect.
Comment 4 Benoit Girard (:BenWa) 2012-01-29 10:50:52 PST
I'm also on 10.7 running on the Discrete GPU.
Comment 5 Andrew McCreight [:mccr8] 2012-01-29 11:04:14 PST
*** Bug 722177 has been marked as a duplicate of this bug. ***
Comment 6 Andrew McCreight [:mccr8] 2012-01-29 11:05:20 PST
It happens to me on 10.6, on TechCrunch.
Comment 7 Andrew McCreight [:mccr8] 2012-01-29 11:05:41 PST
It was much worse on a local debug build.
Comment 8 Byron Jones ‹:glob› 2012-01-29 11:07:08 PST
*** Bug 722170 has been marked as a duplicate of this bug. ***
Comment 9 Joe Drew (not getting mail) 2012-01-29 11:17:25 PST
I can reproduce this on 10.6, but only with integrated graphics.
Comment 10 Joe Drew (not getting mail) 2012-01-29 11:19:07 PST
I'm bisecting.
Comment 11 Michael 2012-01-29 12:09:10 PST
I'm also getting it on the same build on 10.7.2.  This is on a Mac Pro with a Radeon HD 4870.  I get it when scrolling rapidly through a page of images (A facebook photo gallery is a good example).  I also get corruption in the tab bar.
Comment 12 Joe Drew (not getting mail) 2012-01-29 16:12:30 PST
The first bad revision is:
changeset:   85562:9699edcbcedd
user:        George Wright <george@mozilla.com>
date:        Tue Jan 24 19:44:48 2012 -0500
summary:     Bug 721467 - Add an optional codepath (currently enabled only for Adreno 200 GPUs) to only use glTexImage2D for texture uploads as glTexSubImage2D can be slow and/or buggy r=joe,BenWa

Currently running a build to make sure that backing it out fixes this bug.
Comment 13 George Wright (:gw280) (:gwright) 2012-01-29 16:24:46 PST
I can reproduce this on 10.7 but only on the integrated gfx...
Comment 14 Justin Dolske [:Dolske] 2012-01-29 17:45:25 PST
FWIW, I can reproduce it scrolling through this bug, on 10.6.
Comment 15 Abdullah Diaa 2012-01-29 19:18:39 PST
i can reproduce it too by scrolling the page on 10.6 and 10.7 and its fix by disabling hardware accelerator from settings
Comment 16 Joe Drew (not getting mail) 2012-01-30 08:06:31 PST
*** Bug 722314 has been marked as a duplicate of this bug. ***
Comment 17 Abdullah Diaa 2012-01-30 09:03:29 PST
FIXED WITH LAST UPDATE :)
Comment 18 Benoit Girard (:BenWa) 2012-01-30 09:32:09 PST
Fixed for me as well
Comment 19 Joe Drew (not getting mail) 2012-01-30 10:16:51 PST
Crap, sorry. I thought I'd commented in this bug!

I backed out bug 721467 in https://hg.mozilla.org/mozilla-central/rev/d10da858631a .

Note You need to log in before you can comment on or make changes to this bug.