The default bug view has changed. See this FAQ.

Stop doing a recursive chmod on directories every time we upload to a candidates dir

RESOLVED FIXED

Status

Release Engineering
Release Automation
P2
normal
RESOLVED FIXED
5 years ago
2 years ago

People

(Reporter: nthomas, Assigned: nthomas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [release][automation])

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Bug 484972 added a recursive chmod on dirs, to make sure the permissions were set safely on all candidate sub-directories. But didn't think about performance at all in the face of a busy netapp. Now you upload a log (while a virus scan is running amongst multiple other things), and the post_upload bogs down doing chmod that it needn't.

Updated

5 years ago
Assignee: nobody → coop
Priority: -- → P3
Hardware: x86 → All
(Assignee)

Comment 1

5 years ago
Lets get this done asap to try to dig stage out of it's hole.
Assignee: coop → nrthomas
Priority: P3 → P2
(Assignee)

Comment 2

5 years ago
Created attachment 595621 [details] [diff] [review]
[tools] Disable chmod for release to candidates

As far as we can tell this code isn't necessary, because dirs are created 755 and files set to 644, but we will find out when we do the next release when check_permissions runs.
Attachment #595621 - Flags: review?(catlee)

Updated

5 years ago
Attachment #595621 - Flags: review?(catlee) → review+
(Assignee)

Comment 3

5 years ago
Comment on attachment 595621 [details] [diff] [review]
[tools] Disable chmod for release to candidates

http://hg.mozilla.org/build/tools/rev/4988e5cda458
Attachment #595621 - Flags: checked-in+
(Assignee)

Comment 4

5 years ago
Deployed to stage.m.o.
I think we have a problem with this on bug 729998.
We don't know though why it would show up for beta4 rather than beta 2 & 3 as well.
Duplicate of this bug: 733726
Mass move of bugs to Release Automation component.
Component: Release Engineering → Release Engineering: Automation (Release Automation)
Flags: checked-in+
No longer blocks: 714371
Product: mozilla.org → Release Engineering
Looks like we still do this for mobile candidates directories: https://hg.mozilla.org/build/tools/file/default/stage/post_upload.py#l364
(Assignee)

Comment 9

2 years ago
Created attachment 8547413 [details] [diff] [review]
[tools] Remove dirs chmod for mobile candidates too

Only 79 dirs in a mobile candidate dir vs 1500+ for desktop so not as big of a problem. Here's the patch for completeness anyway.
Attachment #8547413 - Flags: review?(bhearsum)
Attachment #8547413 - Flags: review?(bhearsum) → review+
(Assignee)

Comment 10

2 years ago
Comment on attachment 8547413 [details] [diff] [review]
[tools] Remove dirs chmod for mobile candidates too

Canonical copy:
https://hg.mozilla.org/build/tools/rev/42ba198e06d4

Deployed using IT puppet:
Committed revision 99145.
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.