Last Comment Bug 722211 - Update WebGL conformance tests to r16765 and adapt mochitest to harness changes
: Update WebGL conformance tests to r16765 and adapt mochitest to harness changes
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Canvas: WebGL (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Benoit Jacob [:bjacob] (mostly away)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-29 18:31 PST by Benoit Jacob [:bjacob] (mostly away)
Modified: 2012-01-30 19:15 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Benoit Jacob [:bjacob] (mostly away) 2012-01-29 18:31:27 PST
Since 15330 the standard webgl test harness wants to load test lists asynchronously. We were patching our copy to avoid having to adapt to that. Fixing that now.

Along the way I found a little problem: test harness seems to hardcode the idea that when test lists are loaded, we don't immediately start running them, instead we just enable a button that the user can click to run tests. That doesn't work for us: we want to run tests as soon as test lists are loaded, and we run into a problem -> patching upstream

Also, options may now be specified in test lists. adapting to that.

try:
https://tbpl.mozilla.org/?tree=Try&rev=d1e18e947328
Comment 1 Benoit Jacob [:bjacob] (mostly away) 2012-01-30 11:02:53 PST
http://hg.mozilla.org/integration/mozilla-inbound/rev/a308b2b991cb
Comment 2 Matt Brubeck (:mbrubeck) 2012-01-30 19:15:56 PST
https://hg.mozilla.org/mozilla-central/rev/a308b2b991cb

Note You need to log in before you can comment on or make changes to this bug.