Closed Bug 722214 Opened 8 years ago Closed 8 years ago

My debug profile now aborts debug Firefox builds in ipc/chromium/src/base/histogram.cc, line 778

Categories

(Toolkit :: Telemetry, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 722545

People

(Reporter: joe, Assigned: froydnj)

Details

I have a debug profile I use, and now when I start a debug trunk build of Firefox, the Chromium histogram code aborts Firefox:

###!!! ABORT: file /Volumes/SSD/src/mozilla-central/ipc/chromium/src/base/histogram.cc, line 778
mozilla::Logger::~Logger()+0x00000145 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x0001CC4B]
mozilla::LogWrapper::~LogWrapper()+0x00000015 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x00001799]
base::Histogram::SampleSet::Deserialize(void**, Pickle const&)+0x0000020A [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x017ED3D0]
(anonymous namespace)::TelemetrySessionData::DeserializeHistogramData(Pickle&, void**)+0x00000149 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x012C995F]
(anonymous namespace)::TelemetrySessionData::LoadFromDisk(nsIFile*, (anonymous namespace)::TelemetrySessionData**)+0x00000275 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x012CC2D7]
(anonymous namespace)::LoadHistogramEvent::Run()+0x00000030 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x012CC37C]
nsThread::ProcessNextEvent(bool, bool*)+0x0000050E [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x01795A7E]
NS_ProcessPendingEvents_P(nsIThread*, unsigned int)+0x00000087 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x017285A8]
nsBaseAppShell::NativeEventCallback()+0x000000B3 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x014D9459]
nsAppShell::ProcessGeckoEvents(void*)+0x00000162 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x014874D6]
__CFRunLoopDoSources0+0x000003FD [/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation +0x0004E27D]
__CFRunLoopRun+0x00000369 [/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation +0x0004C5C9]
CFRunLoopRunSpecific+0x0000023F [/System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation +0x0004BD8F]
RunCurrentEventLoopInMode+0x0000014D [/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox +0x0002E7EE]
ReceiveNextEventCommon+0x00000094 [/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox +0x0002E551]
BlockUntilNextEventMatchingListInMode+0x0000003B [/System/Library/Frameworks/Carbon.framework/Versions/A/Frameworks/HIToolbox.framework/Versions/A/HIToolbox +0x0002E4AC]
_DPSNextEvent+0x000002C4 [/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit +0x00043EB2]
-[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]+0x0000009B [/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit +0x00043801]
-[GeckoNSApplication nextEventMatchingMask:untilDate:inMode:dequeue:]+0x00000070 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x0148578E]
-[NSApplication run]+0x0000018B [/System/Library/Frameworks/AppKit.framework/Versions/C/AppKit +0x0000968F]
nsAppShell::Run()+0x0000007A [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x01486DD8]
nsAppStartup::Run()+0x0000008F [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x011E36EB]
XRE_main+0x00002CA6 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/XUL +0x0002C5CB]
do_main(char const*, int, char**)+0x000003C7 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/./firefox +0x000013B6]
main+0x00000221 [/Volumes/SSD/src/mozilla-central/obj-ff-debug/dist/NightlyDebug.app/Contents/MacOS/./firefox +0x00001B1F]
###!!! ABORT: file /Volumes/SSD/src/mozilla-central/ipc/chromium/src/base/histogram.cc, line 778
Segmentation fault


Everything works fine in a brand-new profile, though.
Nathan please check this and possible get rid of the abort if needed.
Assignee: nobody → nfroyd
Can you provide a sessionHistograms.dat.<mumble> file from your profile directory?  I know how to fix this, but I'm interested in seeing how exactly this happens.
Like I said, I deleted it.  Sorry.

Bug 722625 is much more critical than this one, and fixing that will probably involve fixing this as well.
I was actually asking Joe, seeing as how he filed the bug. :)  You probably were confusing this with bug 722545.

Speaking of which, I'm going to mark this as a dup of the other one, just so we can keep these telemetry-on-disk bugs straight.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 722545
Indeed, I was confused.  Sorry!
You need to log in before you can comment on or make changes to this bug.