Last Comment Bug 722245 - IonMonkey: Assertion failure: unexpected operand kind, at ion/x86/Assembler-x86.h:260
: IonMonkey: Assertion failure: unexpected operand kind, at ion/x86/Assembler-x...
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: ---
Assigned To: Jan de Mooij [:jandem]
:
Mentors:
Depends on:
Blocks: 677337
  Show dependency treegraph
 
Reported: 2012-01-30 01:47 PST by Jan de Mooij [:jandem]
Modified: 2012-01-31 00:32 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (1.67 KB, patch)
2012-01-30 02:07 PST, Jan de Mooij [:jandem]
dvander: review+
Details | Diff | Splinter Review

Description Jan de Mooij [:jandem] 2012-01-30 01:47:41 PST
Bug 679804 introduced a new jit-test failure with --ion -n on x86 (tests/basic/testArrayDensityChange.js), because we don't handle "scale operands" in the x86 assembler when storing GC things.
Comment 1 Jan de Mooij [:jandem] 2012-01-30 02:07:39 PST
Created attachment 592639 [details] [diff] [review]
Patch
Comment 2 Jan de Mooij [:jandem] 2012-01-31 00:32:29 PST
https://hg.mozilla.org/projects/ionmonkey/rev/a269ae67a824

Note You need to log in before you can comment on or make changes to this bug.