Turn off more RIL debug messages

RESOLVED DUPLICATE of bug 720747

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 720747
6 years ago
6 years ago

People

(Reporter: mrbkap, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 592735 [details] [diff] [review]
patch

In bug 714974, philikon reduced the output of the RIL worker a bunch, but not completely. I'm not working on RIL stuff, but I'm still seeing a ton of RIL debug spew.

Right now, ril_worker.js uses a global DEBUG flag and checks it before calling debug(), this works for the majority of cases, but there appear to be a bunch of places where the code forgets to check the flag.

Relatedly, there are a few places where an error() function would be useful as they seem to indicate events that are of note even to people who aren't debugging RIL. I don't understand enough RIL to make that change, though. For now, here's a patch that simply disables RIL debug spew when DEBUG is off.
Attachment #592735 - Flags: review?(philipp)
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 720747
Comment on attachment 592735 [details] [diff] [review]
patch

I'd rather add explicit if (DEBUG) checks everywhere to even avoid constructing the debug messages, keeping the worker lean on object allocations. I agree about the error stuff.

In either way, there's already bug 720747, hence the dupe.
Attachment #592735 - Flags: review?(philipp)
You need to log in before you can comment on or make changes to this bug.