Closed Bug 722398 Opened 9 years ago Closed 8 years ago

Can't copy the text in the infobar

Categories

(DevTools :: Inspector, defect, P1)

x86
All
defect

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 21

People

(Reporter: paul, Assigned: Optimizer)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

This used to work. It stopped working. Worked again. And it's broken again. See bug 705932.
Blocks: 716976
Priority: -- → P2
Bug triage, filter on PINKISBEAUTIFUL
Priority: P2 → P1
Duplicate of this bug: 805850
I am having doubts that bug 694958 caused it by adding a html namespace for the -moz-use-select: text; style's selector.
Flags: needinfo?(paul)
Supposedly, no!
I am looking into it deeper.
Flags: needinfo?(paul)
it needs -moz-user-focus: normal; and it works after that. patch coming.
But since the tagname has a text-transform, the copied tag is in capital alphabets :|
Attached patch patchSplinter Review
copying works again.
Assignee: nobody → scrapmachines
Status: NEW → ASSIGNED
Attachment #705951 - Flags: review?(paul)
Comment on attachment 705951 [details] [diff] [review]
patch

I think this one will have to go through Dao :)
Attachment #705951 - Flags: review?(paul)
Attachment #705951 - Flags: review?(dao)
Attachment #705951 - Flags: feedback?(paul)
Attachment #705951 - Flags: review?(dao) → review+
Whiteboard: [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/887fe9aa3466
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/887fe9aa3466
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 21
Attachment #705951 - Flags: feedback?(paul)
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.