Emphasizing text does not work corretly with multiselection

RESOLVED DUPLICATE of bug 683114

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 683114
6 years ago
4 years ago

People

(Reporter: Fernando García Gómez, stripTM, Unassigned)

Tracking

10 Branch
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:11.0a2) Gecko/20120129 Firefox/11.0a2
Build ID: 20120129042007

Steps to reproduce:

-Write a text.
-Perform a multiselection for the text (select multiple pieces of text with (ctrl+clic)).
-Click on the bold buttom.


Actual results:

Only the first piece selected has taken the bold style.


Expected results:

All the selected pieces of text should have taken the bold style.
(Reporter)

Updated

6 years ago
Version: 9 → 10
(Reporter)

Updated

6 years ago
OS: Linux → All
Hi!

I've have been able to reproduce Fernando bug! Following the steps mentioned above..

I have grants to change the bug status... Do We need another confirmation or Can I  change the status from unconfirmed to new?

Best regards!
User Agente: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20120129 Thunderbird/10.0
Build ID: 20120129063944
YOu'd need to loo for duplicate first :-) and then we could change it to new. Did you guys tried in -safe-mode ?
(Reporter)

Comment 3

6 years ago
Ludovic / Pedro, I tested in -safe-mode Windows | Linux. And I looked inside the "Message Compose Window" component bugs and I have not found anything similar.
(In reply to Ludovic Hirlimann [:Usul] from comment #2)
> YOu'd need to loo for duplicate first :-) and then we could change it to
> new. Did you guys tried in -safe-mode ?

Ludovic seems that this is not hapening in safe mode...
(Reporter)

Comment 5

6 years ago
Pedro are you sure? I am re-testing the -safe-mode and it only changes the first element in the selection group.
OS: All → Linux
Version: 10 → 9
(Reporter)

Updated

6 years ago
OS: Linux → All
Version: 9 → 10
(In reply to Fernando García Gómez, stripTM from comment #5)
> Pedro are you sure? I am re-testing the -safe-mode and it only changes the
> first element in the selection group.

so if it doesn't happen in safe mode one of your extension is responsible for that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(In reply to Ludovic Hirlimann [:Usul] from comment #6)
> (In reply to Fernando García Gómez, stripTM from comment #5)
> > Pedro are you sure? I am re-testing the -safe-mode and it only changes the
> > first element in the selection group.
> 
> so if it doesn't happen in safe mode one of your extension is responsible
> for that.


Ludovic, I think you misread Fernando's comment. He actually confirms that the bug *is* reproducible in safe mode for him.

I'm testing this when I arrive home and report back.
Hey... 

Sorry for the delay answering here... 

Fernando is right, the bug is still reproducible in --safe-mode. It's my fault... 

I'm not sure rigth now why I reply that this was working correctly in safe mode. I've checked it and I can confirm that in --safe-mode it has the same behavior only the first selected block gets the change in the format, the other selections remain the same.

I will reaopen it, Ludovic in case that I'm wrong reopening it, just let me know
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: INVALID → ---

Updated

4 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 683114
You need to log in before you can comment on or make changes to this bug.