Trouble editing the MozillaWiki

RESOLVED DUPLICATE of bug 738257

Status

mozilla.org
Webdev
RESOLVED DUPLICATE of bug 738257
7 years ago
6 years ago

People

(Reporter: mlavine, Unassigned)

Tracking

Details

(Reporter)

Description

7 years ago
I'm unable to edit the MozillaWiki - the rich editor won't load and won't let me open any other kind of editor to add to content to a wiki.

Thanks for the help
Can you still edit with the default editor?  I'm not aware that we have a rich editor installed..

Comment 2

7 years ago
This is a bug in our wiki skin. The rich text editor doesn't work, and once you're in it you can't get back out of it. Here's a workaround that will get you back to a usable state.

When you're on an edit page and it's broken, append this to your URL and hit enter:

&useskin=vector

This will load up the stock 'Vector' skin, which works properly... it takes a few seconds for the rich text editor to load, but once it does you can use it or switch back. Once you're switched back, the normal skin/editor should work again.


Assigning to webdev as a mediawiki skin issue. For anyone reading this, we *need* to rewrite our wiki skin... we keep running into problems like this due to poor MediaWiki backwards compatibility... skins must be re-based on the default skin for every major version upgrade.
Assignee: server-ops → nobody
Component: Server Operations: Web Operations → Webdev
QA Contact: cshields → webdev

Updated

7 years ago
Group: infra
(Reporter)

Comment 3

7 years ago
"When you're on an edit page and it's broken, append this to your URL and hit enter:

&useskin=vector

This will load up the stock 'Vector' skin, which works properly... it takes a few seconds for the rich text editor to load, but once it does you can use it or switch back. Once you're switched back, the normal skin/editor should work again."

This allowed me to edit the wiki just fine but after saving the page, the text shows up as a wonky mix of code/links/words. I know I'm entering the info in correctly.

Comment 4

7 years ago
The text that appears wrong... did you enter that with the normal editor or the rich-text editor?

I don't think the rich text editor actually works properly with our skin... I wouldn't try to use it (or use this "%useskin=vector" trick) beyond getting *back* to the normal editor.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 738257
You need to log in before you can comment on or make changes to this bug.