Closed Bug 722566 Opened 8 years ago Closed 8 years ago

# Startup crashes vs. uptime by OS

Categories

(Socorro :: Data request, task, minor)

task
Not set
minor

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: MattN, Unassigned)

Details

Attachments

(1 file)

In bug 294260 I'm adding some code to detect startup crashes and give the user some help.  I would like to find out the distribution of startup crashes to see what proportion of startup crashes would be detected by this feature.  I will use the data to compare with telemetry for this.

Count crashes where Uptime <= 60s
Group by OS, Uptime (in s)

Choose a sample size that you feel would be representative.

Thanks
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #1)
> Do the custom reports I'm already running help you there?

They are similar but don't give me the information I'm looking for which is the distribution of the crashes during startup. ie. I want to be able to see what proportion of crashes happen in the first 10 seconds of uptime.
(In reply to Matthew N. [:MattN] from comment #2)
> (In reply to Robert Kaiser (:kairo@mozilla.com) from comment #1)
> > Do the custom reports I'm already running help you there?
> 
> They are similar but don't give me the information I'm looking for which is
> the distribution of the crashes during startup. ie. I want to be able to see
> what proportion of crashes happen in the first 10 seconds of uptime.

OK, we have the proportion of how many happen within 60 seconds in the signature summary, but we haven't broken them down to smaller slices anywhere.
What I forgot to say, you can actually get the data yourself if you are willing to run some kind of script or other analysis through the *-pub-crashdata.csv.gz files in the dated directories of https://crash-analysis.mozilla.com/crash_analysis/ (I'm not linking one directly as opening a 30+ MB .csv.gz in your browser isn't healthy).
Those files contain a line for every Firefox desktop or mobile crash reported on a given day, we have the uptime in seconds in a column there.
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #4)
> What I forgot to say, you can actually get the data yourself if you are
> willing to run some kind of script or other analysis through the
> *-pub-crashdata.csv.gz files in the dated directories of
> https://crash-analysis.mozilla.com/crash_analysis/ 

Thanks, I was wondering if such data was publicly available. I'll give that a try so this request can go on hold for now.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Whiteboard: [on hold]
That data seems to be good enough for now.  I've attached a graph for Windows of what I was looking for in case anybody is interested.
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [on hold]
You need to log in before you can comment on or make changes to this bug.