Failed To Generate C++ Header File And XPT File With Gecko 10 Beta 5

RESOLVED DUPLICATE of bug 723861

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 723861
6 years ago
6 years ago

People

(Reporter: thensiujing, Unassigned)

Tracking

10 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0.1) Gecko/20110504 Firefox/4.0.1
Build ID: 20110504035914

Steps to reproduce:

Generate C++ header file with the command based on https://developer.mozilla.org/en/XPIDL/pyxpidl:
1. sdkdir/sdk/bin/header.py -o <outputfilename.h> <filename.idl> 
2. sdkdir/sdk/bin/typelib.py -o <oputputfilename.xpt> <filename.idl>


Actual results:

The errors I got are:
C:\PSC9\SAFEWEB_SDK_DIR\xulrunner-10.0b5.en-US.win32.sdk\xulrunner-sdk\idl>python ..\sdk\bin\header.py -o ILitmusFF10.h ILitmusFF10.idl
Traceback (most recent call last):
  File "..\sdk\bin\header.py", line 497, in <module>
    p = xpidl.IDLParser(outputdir=options.cachedir)
  File "C:\PSC9\SAFEWEB_SDK_DIR\xulrunner-10.0b5.en-US.win32.sdk\xulrunner-sdk\sdk\bin\xpidl.py", line 1453, in __init__
    optimize=1)
  File "C:\PSC9\SAFEWEB_SDK_DIR\xulrunner-10.0b5.en-US.win32.sdk\xulrunner-sdk\sdk\bin\ply\lex.py", line 1004, in lex
    lexobj.writetab(lextab,outputdir)
  File "C:\PSC9\SAFEWEB_SDK_DIR\xulrunner-10.0b5.en-US.win32.sdk\xulrunner-sdk\sdk\bin\ply\lex.py", line 175, in writetab
    filename = os.path.join(outputdir,basetabfilename)+".py"
  File "C:\PSC9\TOOLS_ROOT\python\lib\ntpath.py", line 96, in join
    assert len(path) > 0
TypeError: object of type 'NoneType' has no len()

C:\PSC9\SAFEWEB_SDK_DIR\xulrunner-10.0b5.en-US.win32.sdk\xulrunner-sdk\idl>python ..\sdk\bin\typelib.py -o ILitmusFF10.xpt ILitmusFF10.idl
Traceback (most recent call last):
  File "..\sdk\bin\typelib.py", line 313, in <module>
    p = xpidl.IDLParser(outputdir=options.cachedir)
  File "C:\PSC9\SAFEWEB_SDK_DIR\xulrunner-10.0b5.en-US.win32.sdk\xulrunner-sdk\sdk\bin\xpidl.py", line 1453, in __init__
    optimize=1)
  File "C:\PSC9\SAFEWEB_SDK_DIR\xulrunner-10.0b5.en-US.win32.sdk\xulrunner-sdk\sdk\bin\ply\lex.py", line 1004, in lex
    lexobj.writetab(lextab,outputdir)
  File "C:\PSC9\SAFEWEB_SDK_DIR\xulrunner-10.0b5.en-US.win32.sdk\xulrunner-sdk\sdk\bin\ply\lex.py", line 175, in writetab
    filename = os.path.join(outputdir,basetabfilename)+".py"
  File "C:\PSC9\TOOLS_ROOT\python\lib\ntpath.py", line 96, in join
    assert len(path) > 0
TypeError: object of type 'NoneType' has no len()


Expected results:

Both C++ header and xpt file should be generated in the same folder that contains <filename.idl>.

Updated

6 years ago
Component: XPCOM → Build Config
QA Contact: xpcom → build-config
Yeah, you need a --cachedir=<path> option too.  I'll update the docs.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 723861
You need to log in before you can comment on or make changes to this bug.