Closed Bug 722658 Opened 8 years ago Closed 8 years ago

worker stops before finishing task

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 711388

People

(Reporter: eviljeff, Unassigned)

Details

Attachments

(2 files)

From this forum post:
https://forums.mozilla.org/addons/viewtopic.php?f=11&t=4474

"I use a worker js to read a csv file, tokenize it and create sql statements from the read data.
For files of size nearly 3 MB, the worker thread hangs without any error being shown in error console or web console."

"Firefox does not become unresponsive. The addon's main thread displays a string sent by the worker's postmessage and I have no idea whether the worker has hanged or what? I use postMessage to debug the worker. Even after putting all the code where I receive the last postMessage from in try...catch, I get no error in web/error console. I know the worker does not complete because the strings in postMessage help me figure that out.
This problem was not there earlier with some earlier version of firefox where I could run this worker perfectly well for files of 10-20 MBs too."

"Tried with Firefox 5.0, 6.0, 7.0 and 7.0.1. It works as expected.

Tried with firefox 8.0/9.0.1: hangs as originally reported"
Ben, is this the OOM thing?
I am almost certain that it is (bug 711388). Please try with Firefox 11 or 12 (now beta and aurora, I think, since we merged today?) and see if this still happens. If so then it's a new bug. Otherwise we need to dup to bug 711388.
Its working for me in Firefox 11 so marking as fixed.  

lazierthanthou - add a commment if you're still experiencing it in Firefox 11 or 12/
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 711388
(In reply to Andrew Williamson [:eviljeff] from comment #4)
> Its working for me in Firefox 11 so marking as fixed.  
> 
> lazierthanthou - add a commment if you're still experiencing it in Firefox
> 11 or 12/

tried with firefox 11.0a2. It worked.
You need to log in before you can comment on or make changes to this bug.