Web Telephony:add duration attribute to the call object

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: oteo, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/534.51.22 (KHTML, like Gecko) Version/5.1.1 Safari/534.51.22



Actual results:

The dialer application needs to keep track of the call duration even when the dialer is not active but the call is ongoing


Expected results:

 We suggest to have a call duration attribute in the call object in order to keep track of the call duration in the platform.
(In reply to Maria Angeles Oteo from comment #0)
> The dialer application needs to keep track of the call duration even when
> the dialer is not active but the call is ongoing

Why would the dialer not be active when there's a call ongoing?
Blocks: webtelephony
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 2

7 years ago
(In reply to Philipp von Weitershausen [:philikon] from comment #1)
> (In reply to Maria Angeles Oteo from comment #0)
> > The dialer application needs to keep track of the call duration even when
> > the dialer is not active but the call is ongoing
> 
> Why would the dialer not be active when there's a call ongoing?

Because, for example, the user presses the Homescreen button and, as a consequence, the dialer goes to the background and the homescreen to the foreground. In that case, for instance, the homescreen could display a notification bar indicating that there is a ongoing call.
The dialer app would probably still need to be kept running, just in the background. It seems unlikely that we'll want to shut down such a critical app and reconstruct all it's state while a phone call is in progress.
I think we should let the dialer app deal with call duration. We can reopen if we change our minds.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.