Last Comment Bug 722663 - open a new tab from Panorama view should reference gWindow.BROWSER_NEW_TAB_URL
: open a new tab from Panorama view should reference gWindow.BROWSER_NEW_TAB_URL
Status: VERIFIED FIXED
[qa!]
:
Product: Firefox Graveyard
Classification: Graveyard
Component: Panorama (show other bugs)
: 12 Branch
: All All
: -- normal
: Firefox 13
Assigned To: teramako
:
Mentors:
: 617781 (view as bug list)
Depends on: 455553
Blocks: 648286
  Show dependency treegraph
 
Reported: 2012-01-31 04:39 PST by teramako
Modified: 2016-04-12 14:00 PDT (History)
4 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
panorama_groupItem_newtab.patch (568 bytes, patch)
2012-01-31 04:39 PST, teramako
ttaubert: review+
Details | Diff | Splinter Review
patch v1 (2.75 KB, patch)
2012-02-02 06:42 PST, Tim Taubert [:ttaubert]
no flags Details | Diff | Splinter Review
patch v2 (3.27 KB, patch)
2012-02-02 07:20 PST, Tim Taubert [:ttaubert]
dietrich: review+
Details | Diff | Splinter Review

Description teramako 2012-01-31 04:39:06 PST
Created attachment 593046 [details] [diff] [review]
panorama_groupItem_newtab.patch

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120130 Firefox/12.0a1
Build ID: 20120130031142

Steps to reproduce:

1. open about:config
2. edit "browser.newtab.url" to "about:newtab"
3. restart Firefox
4. open Panorama
5. create new group and click the group
6. then opens about:blank page

GroupItem.prototype.newTab method should open "gWindow. BROWSER_NEW_TAB_URL" if the arguments are omitted or blank.
Comment 1 Tim Taubert [:ttaubert] 2012-02-02 03:24:47 PST
Comment on attachment 593046 [details] [diff] [review]
panorama_groupItem_newtab.patch

Review of attachment 593046 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks for your patch! Can you please package this so that I can check it in?
Comment 2 Tim Taubert [:ttaubert] 2012-02-02 03:26:53 PST
*** Bug 617781 has been marked as a duplicate of this bug. ***
Comment 3 teramako 2012-02-02 05:28:45 PST
(In reply to Tim Taubert [:ttaubert] from comment #1)
> Comment on attachment 593046 [details] [diff] [review]
> panorama_groupItem_newtab.patch
> 
> Review of attachment 593046 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Looks good, thanks for your patch! Can you please package this so that I can
> check it in?

I don't have the privilege to check in, so could you do ?
And I'm not familiar with mercurial, so I don't know how to package my patch :(
Comment 4 Tim Taubert [:ttaubert] 2012-02-02 05:54:59 PST
Ok, no problem. I'll do it.
Comment 5 Tim Taubert [:ttaubert] 2012-02-02 06:42:25 PST
Created attachment 593820 [details] [diff] [review]
patch v1

There was a test that needed a fix and another one threw an error, sorry for not catching this earlier.
Comment 6 Tim Taubert [:ttaubert] 2012-02-02 07:20:05 PST
Created attachment 593831 [details] [diff] [review]
patch v2

Uses now a not so hacky workaround for the 'gPage is not defined' error.
Comment 7 Dão Gottwald [:dao] 2012-02-02 08:35:59 PST
What exactly does gPage have to do with this bug?
Comment 8 Tim Taubert [:ttaubert] 2012-02-02 09:16:50 PST
Using 'about:newtab' as the new tab page leads to a strange error while running tabview tests. gPage seems undefined although newTab.js is loaded right before. This is probably caused because we're quickly opening and closing tabs. We can simply fix this by combining those two scripts.
Comment 9 Tim Taubert [:ttaubert] 2012-02-03 01:43:52 PST
https://hg.mozilla.org/integration/fx-team/rev/5be3a6666dd4
Comment 10 Tim Taubert [:ttaubert] 2012-02-04 02:37:18 PST
https://hg.mozilla.org/mozilla-central/rev/5be3a6666dd4
Comment 11 Virgil Dicu [:virgil] [QA] 2012-02-28 02:48:03 PST
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:13.0) Gecko/20120227 Firefox/13.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:13.0) Gecko/20120227 Firefox/13.0a1
Mozilla/5.0 (Windows NT 6.1; rv:13.0) Gecko/20120227 Firefox/13.0a1

Verified on Firefox 13, latest Nightly. The new tab page is displayed when selecting an empty tab group.

Note You need to log in before you can comment on or make changes to this bug.